Bug 591434 - firstboot rhn_* modules not loaded
firstboot rhn_* modules not loaded
Status: CLOSED DUPLICATE of bug 585188
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jan Pazdziora
Red Hat Satellite QA List
: Regression
Depends On:
Blocks: 582655 559492
  Show dependency treegraph
 
Reported: 2010-05-12 05:04 EDT by Jiri Kastner
Modified: 2010-05-25 11:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-25 11:33:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
firstboot without rhn related items (103.09 KB, image/png)
2010-05-12 05:04 EDT, Jiri Kastner
no flags Details

  None (edit)
Description Jiri Kastner 2010-05-12 05:04:43 EDT
Created attachment 413366 [details]
firstboot without rhn related items

Description of problem:
firstboot rhn_* modules not loaded, therefore system is not able register to rhn|spacewalk

Version-Release number of selected component (if applicable):

#rpm -qa rhn-setup rhn-setup-gnome rhn-client-tools firstboot
rhn-setup-gnome-1.0.0-3.el6.noarch
rhn-client-tools-1.0.0-3.el6.noarch
rhn-setup-1.0.0-3.el6.noarch
firstboot-1.110.1-1.el6.ppc64


How reproducible:
always

Steps to Reproduce:
1. install rhel6 on any platform
2. run firstboot (maybe 'sed -i "s/=NO/=YES/" /etc/sysconfig/firstboot' and 'rm -f /etc/sysconfig/rhn/systemid*'
3. check results
  
Actual results:
[root@ibm-js22-vios-02-lp2 ~]# firstboot 
firstboot ERROR: Error loading module rhn_create_profile_gui:
No module named functions
firstboot ERROR: Error loading module rhn_register_firstboot_gui_window:
No module named functions
firstboot ERROR: Error loading module rhn_finish_gui:
No module named functions
firstboot ERROR: Error loading module rhn_choose_server_gui:
No module named functions
firstboot ERROR: Error loading module rhn_review_gui:
No module named functions
firstboot ERROR: Error loading module rhn_start_gui:
No module named functions
firstboot ERROR: Error loading module rhn_login_gui:
No module named functions
firstboot ERROR: Error loading module rhn_provide_certificate_gui:
No module named functions
Loading /lib/kbd/keymaps/i386/qwerty/us.map.gz
/usr/share/firstboot/modules/firstboot_kdump.py:211: GtkWarning: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
  self.kdumpMem = gtk.SpinButton(self.memSpin, 0, 0)


Expected results:
no error mesages regarding loading rhn modules. and firstboot allow you to register system to rhn|spacewalk

Additional info:
Comment 3 Jan Pazdziora 2010-05-25 11:32:29 EDT
Taking.
Comment 4 Jan Pazdziora 2010-05-25 11:33:44 EDT
To simplify the world, let's call this a duplicate of bugzilla 585188 where we address changing RHN Register part of firstboot to match the firstboot version in RHEL 6.

*** This bug has been marked as a duplicate of bug 585188 ***

Note You need to log in before you can comment on or make changes to this bug.