Bug 591442 - not able subscribe to rhn.errata.stage rhel6-beta channel on ppc
not able subscribe to rhn.errata.stage rhel6-beta channel on ppc
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: releng (Show other bugs)
6.0
ppc64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Dennis Gregorovic
Release Test Team
: Regression, Reopened
Depends On:
Blocks: 582655 559491 559492 584464
  Show dependency treegraph
 
Reported: 2010-05-12 05:34 EDT by Jiri Kastner
Modified: 2014-01-15 15:08 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 11:22:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Kastner 2010-05-12 05:34:59 EDT
Description of problem:
not able subscribe to rhn.errata.stage rhel6-beta channel on ppc.
with activation key none channel subscribed. without activation key getting Error Class Code: 70

Version-Release number of selected component (if applicable):
[root@ibm-js22-vios-02-lp2 ~]# rpm -q rhn-client-tools rhn-setup rhn-setup-gnome
rhn-client-tools-1.0.0-3.el6.noarch
rhn-setup-1.0.0-3.el6.noarch
rhn-setup-gnome-1.0.0-3.el6.noarch


How reproducible:
always on ppc

Steps to Reproduce:
1. install rhel6 on ppc
2. run rhn_register or rhnreg_ks
3. check results
  
Actual results:
Error Class Code: 70
Error Class Info: 
     All available subscriptions for the requested channel have been exhausted.
     Please contact a Red Hat Network Sales associate.
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.


Expected results:
subscribed to appropriate channel 

Additional info:
Comment 1 Dennis Gilmore 2010-05-24 10:15:59 EDT
Is this just related to the change in the base arch for EL-6 from ppc to ppc64?
Comment 2 Dennis Gregorovic 2010-05-25 09:24:06 EDT
Do you get this error with other arches?
Comment 3 Stephen Herr 2010-05-25 10:15:39 EDT
Looking at your account in webdev (which I assume is the same as production, though I don't have access to it), you are getting the out-of-available-subscriptions error because you don't have any available subscriptions. It looks like you have 1 update entitlement and 0 channel entitlements of any kind. You must have channel entitlements to rhel-server (or in this case maybe rhel-server-beta) in order to be able to register anything. Go to "Your RHN" -> "Subscription Management" -> "Software Channel Entitlements" to see which families of channels you have access too, currently in webdev it's none.

Am I correct in assuming that you are using the "jkastner" login to register this machine? If so how did you get your entitlements into this state?
Comment 4 Jiri Kastner 2010-05-26 03:31:47 EDT
(In reply to comment #3)
> Looking at your account in webdev (which I assume is the same as production,
> though I don't have access to it), you are getting the
> out-of-available-subscriptions error because you don't have any available
> subscriptions. It looks like you have 1 update entitlement and 0 channel
> entitlements of any kind. You must have channel entitlements to rhel-server (or
> in this case maybe rhel-server-beta) in order to be able to register anything.
> Go to "Your RHN" -> "Subscription Management" -> "Software Channel
> Entitlements" to see which families of channels you have access too, currently
> in webdev it's none.
> 
> Am I correct in assuming that you are using the "jkastner" login to register
> this machine? If so how did you get your entitlements into this state?    

no, bug is about errata.stage, not webdev
Comment 9 Dethlef Madsen 2010-05-26 11:18:11 EDT
I get exactly the same error message after installation of rhel 6 beta. 

#~: rhn_register
  
Arch is x86_64. I will not tell you the account in this pulbic area here - search for host cyrus.ikk-nord.de for example.

We have 9 registered hosts and 1 unused basic subscription and I cannot register the host.
Comment 10 Stephen Herr 2010-05-26 13:13:19 EDT
(In reply to comment #9)
> I get exactly the same error message after installation of rhel 6 beta. 
> 
> #~: rhn_register
> 
> Arch is x86_64. I will not tell you the account in this pulbic area here -
> search for host cyrus.ikk-nord.de for example.
> 
> We have 9 registered hosts and 1 unused basic subscription and I cannot
> register the host.    

Dethlef, I strongly suspect that your issue is related to your individual account, since I am able to register an x86_64 RHEL 6 Beta machine just fine. For that you should talk to our customer support department: http://www.redhat.com/support/policy/sla/contact/

If they cannot help you and/or they tell you to file a bug, please do let us know.
Comment 11 Dennis Gregorovic 2010-05-26 13:20:45 EDT
There's some confusion here.  This bug only pertains to rhn.errata.stage environment, which is internal to Red Hat's infrastructure.  The public-facing rhn.redhat.com does not have any RHEL 6 channels at this point and subscribing to RHN with RHEL 6.0 Beta 1 is not supported.  We are working on getting the pieces in place so that channels and registration are available in the upcoming RHEL 6.0 Beta 2 release.
Comment 12 Dethlef Madsen 2010-05-26 14:09:08 EDT
(In reply to comment #11)
> There's some confusion here.  This bug only pertains to rhn.errata.stage
> environment, which is internal to Red Hat's infrastructure.  The public-facing
> rhn.redhat.com does not have any RHEL 6 channels at this point and subscribing
> to RHN with RHEL 6.0 Beta 1 is not supported.  We are working on getting the
> pieces in place so that channels and registration are available in the upcoming
> RHEL 6.0 Beta 2 release.    

Ok ,thank you very much. I was confused because I can download the Beta from inside my account and cannot register the installed host.

Thanks again.
Comment 60 releng-rhel@redhat.com 2010-11-11 11:22:47 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.