This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 591467 - [abrt] crash in ruby-1.8.6.399-1.fc12: raise: Process /usr/bin/ruby was killed by signal 6 (SIGABRT)
[abrt] crash in ruby-1.8.6.399-1.fc12: raise: Process /usr/bin/ruby was kille...
Status: CLOSED DUPLICATE of bug 593746
Product: Fedora
Classification: Fedora
Component: ruby (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
abrt_hash:2d8a3519f2d10dae4b6428e9fde...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-12 06:31 EDT by hugotrip
Modified: 2010-05-19 11:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-19 11:59:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (67.08 KB, text/plain)
2010-05-12 06:31 EDT, hugotrip
no flags Details

  None (edit)
Description hugotrip 2010-05-12 06:31:54 EDT
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: ruby /usr/bin/alexandria
component: ruby
crash_function: raise
executable: /usr/bin/ruby
global_uuid: 2d8a3519f2d10dae4b6428e9fde185f01b19c04c
kernel: 2.6.32.11-99.fc12.x86_64
package: ruby-1.8.6.399-1.fc12
rating: 4
reason: Process /usr/bin/ruby was killed by signal 6 (SIGABRT)
release: Fedora release 12 (Constantine)
How to reproduce: just closing Alexandria
Comment 1 hugotrip 2010-05-12 06:31:58 EDT
Created attachment 413392 [details]
File: backtrace
Comment 2 Mamoru TASAKA 2010-05-13 12:03:27 EDT
It seems that this is basically the same as bug 530407.
Comment 3 Mamoru TASAKA 2010-05-13 12:07:36 EDT
Ah, it seems wrong, sorry...
Comment 4 Mamoru TASAKA 2010-05-14 15:54:55 EDT
Hi:

- Is this bug reproducible even if you remove (or backup)
  ~/.alexandria ? If not, would you attach the whole tree
  of ~/.alexandria?

- How often is this bug reproducible? Also would you write
  the needed procedure before closing alexandria to reproduce
  this issue?
Comment 5 hugotrip 2010-05-16 15:15:44 EDT
This was a one time bug: I just opened Alexandria to check if I already registered a book: I used the filter to find it, and as it was registered, I simply quit the application, which crashed, with no apparent reason.

Furthermore, there has been an update of alexandria this week-end, so I don't know if it's useful to upload my ~/.alexandria folder (which is 7,6 Mio big, because of the pictures of the covers)
Comment 6 Mamoru TASAKA 2010-05-17 11:23:06 EDT
Well, the change between 0.6.6 beta1 -> 0.6.6 beta2 is mainly
to add a new provider, and the crash reported on this bug is not
the syntax errors or so in alexandria scripts but segv having
occurred in ruby itself. So the update of alexandria shouldn't
affect this issue.

By the way now ruby 1.8.6.399-3 is in testing, which contains
a bug fix for null klass issue. Would you try the testing ruby?
Comment 7 hugotrip 2010-05-18 06:33:46 EDT
Shouldn't I wait for the ruby 1.8.6.399-4 to be pushed in testing, as I see you've submitted it in Bodhi ?
Comment 8 Mamoru TASAKA 2010-05-18 07:09:36 EDT
-4 addressed a issue completely different from this issue
and you can try -3.
Comment 9 hugotrip 2010-05-19 11:46:24 EDT
I've updated with -4 which is now the testing update. I didn't reproduced this bug, but got another one: https://bugzilla.redhat.com/show_bug.cgi?id=593746
Comment 10 Mamoru TASAKA 2010-05-19 11:59:52 EDT
From backtrace the crash seem to be occuring at the same place.
Once closing as a duplicate of the new one you've filed for triage.

*** This bug has been marked as a duplicate of bug 593746 ***

Note You need to log in before you can comment on or make changes to this bug.