Bug 59148 - missing in_addr_t type definition
Summary: missing in_addr_t type definition
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: ucd-snmp (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-31 19:25 UTC by rm0
Modified: 2015-03-05 01:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-24 10:26:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description rm0 2002-01-31 19:25:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT)

Description of problem:
This bug can be seen as an upstream one.

Missing in_addr_t type definition causes compilation of software that uses ucd-
snmp include files.

Version-Release number of selected component (if applicable):
4.2.3-4

How reproducible:
Always

Steps to Reproduce:
1. Try to compile a package/tarball that BuilReq ucd-snmpd-devel (I'm 
using cyrus-imapd that acts as an AgentX sub-agent).
2. 
3.


Actual Results:  The compilation fails at the 

in_addr_t get_myaddr (void); 

prototype in snmplib/system.h because the in_addr_t 
data type is unknown at that point.

ucd-snmp 4.2.1 included <netinet/in.h> at the top of 
snmplib/ucd-snmp-includes.h but in the 4.2.3 this 
changed and this is causing the compilaton error.

It can be solved by re-adding it again (PLD
people solved it that way in their 4.2.2 packages so that's 
the ucd-snmp version where the bug appeared) or by uncommenting
the

/* typedef u_int in_addr_t; */
 
lines located two lines below in the same file as suggested 
(this one is not very elegant becasue in_addr_t is in fact
defined in netinet/in.h).


Expected Results:  It should compile flawlessly. This problem 
can be a showstopper to the successful building on other 
packages that depends on ucd-snmp (MRTG?, Ethereal?, ...).

Additional info:

Comment 1 Phil Knirsch 2002-02-24 10:26:31 UTC
Strange. I've successfully rebuilt ethereal with the newest errata version of
ucd-snmp without that problem. Have you changed anything on the cyrus-impd
package or is this the srpm directly from the distribution?

Read ya, Phil

Comment 2 Phil Knirsch 2002-04-09 12:50:33 UTC
As i can't reproduce this problem and haven't heard back from the original
submitter i am closing this bug as WORKSFORME now.

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.