Bug 591537 - RFE: implement restart action in sandbox init script
Summary: RFE: implement restart action in sandbox init script
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: policycoreutils   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Daniel Walsh
QA Contact: Milos Malik
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-12 14:20 UTC by Milos Malik
Modified: 2010-07-02 19:43 UTC (History)
5 users (show)

Fixed In Version: policycoreutils-2.0.82-28.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 19:43:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Milos Malik 2010-05-12 14:20:11 UTC
Description of problem:
1) "restart" action is not implemented in the init script
2) "status" action is implemented but not advertised when I run "service sandbox"

Version-Release number of selected component (if applicable):
policycoreutils-sandbox-2.0.82-14.el6

How reproducible:
always

Steps to Reproduce:

  
Actual results:


Expected results:

Comment 1 Daniel Walsh 2010-05-12 14:48:05 UTC
sandbox initrc script is not a standard init script.  It is just something that needs to be run at boot time.  It does not start a service, it just sets up the file system so tools like sandbox and xguest/mls environments can use pam_namespace

Unless Bill has a better location for this,  I think we have to close this as not a bug.

Comment 2 Bill Nottingham 2010-05-12 16:46:34 UTC
You could theoretically make it an upstart event, but that's probably overkill.

Comment 3 Eduard Benes 2010-05-13 14:54:09 UTC
There seem to be two options for this bug: 

1) (preferred) Find better location for it. 
2) (easier) Despite the fact it is not a standard init script I think it would be good and easy to implement few actions required by init script quidelines. This is something we successfully accomplished in RHEL 6 init script project [1] for most components. 

Fedora guidelines for init scripts [2] provide details what is the minimum expected from this bug. But we definitely shouldn't close this bug as a not a bug. 

[1] http://wiki.test.redhat.com/BaseOs/Projects/InitScripts
[2] https://fedoraproject.org/wiki/Packaging/SysVInitScript

Comment 6 Daniel Walsh 2010-06-09 20:21:47 UTC
Fixed in policycoreutils-2.0.82-28.el6

Comment 9 releng-rhel@redhat.com 2010-07-02 19:43:06 UTC
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.