Bug 591573 - update to latest version of pstreams
update to latest version of pstreams
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pstreams-devel (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Rakesh Pandit
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-12 11:22 EDT by Jonathan Wakely
Modified: 2010-05-31 14:25 EDT (History)
1 user (show)

See Also:
Fixed In Version: pstreams-devel-0.7.0-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-31 14:23:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
updated spec file (2.01 KB, application/octet-stream)
2010-05-12 11:22 EDT, Jonathan Wakely
no flags Details
spec file that actually works (1.98 KB, text/plain)
2010-05-12 11:46 EDT, Jonathan Wakely
no flags Details

  None (edit)
Description Jonathan Wakely 2010-05-12 11:22:11 EDT
Created attachment 413458 [details]
updated spec file

Description of problem:

Fedora ships with version 0.6.0 of pstreams, I've just released 0.7.0 and would like to have that version in fedora

Version-Release number of selected component (if applicable):

pstreams-devel-0.6.0-8.fc12.noarch


Additional info:

the upstream tarball now includes a spec file, and I've incorporated the patch from the pstreams-devel SRPM, so it is unnecessary now.

There is one change in behaviour in the new release: when opening a pstream for reading with pstderr the pstdout mode is no longer added automatically, and the initial read source will be set to the child process' stderr stream.
I've checked the pdf2djvu package and its use of pstreams will not be affected, because it explicitly passes both pstdout|pstderr to the ipstream constructor.
Comment 1 Jonathan Wakely 2010-05-12 11:30:55 EDT
that spec file doesn't work!  sorry, I'll fix it and update it
Comment 2 Jonathan Wakely 2010-05-12 11:46:48 EDT
Created attachment 413463 [details]
spec file that actually works

The spec file that  I attached here isn't the one I tested in %_topdir/SPECS - oops.
I've updated the release tarball with the right spec file and am attaching it here
Comment 3 Rakesh Pandit 2010-05-13 01:03:49 EDT
Thanks Jonathan, for work in upstream and patching up spec. I have applied your patch as it is (after review). I will build and push updates in a while. They will first go to update testing and take a week or two before getting into stable releases.

Thanks,
Comment 4 Fedora Update System 2010-05-13 01:13:43 EDT
pstreams-devel-0.7.0-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/pstreams-devel-0.7.0-1.fc12
Comment 5 Fedora Update System 2010-05-13 01:14:20 EDT
pstreams-devel-0.7.0-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/pstreams-devel-0.7.0-1.fc13
Comment 6 Fedora Update System 2010-05-13 15:25:23 EDT
pstreams-devel-0.7.0-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pstreams-devel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/pstreams-devel-0.7.0-1.fc13
Comment 7 Fedora Update System 2010-05-13 15:31:40 EDT
pstreams-devel-0.7.0-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pstreams-devel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/pstreams-devel-0.7.0-1.fc12
Comment 8 Jonathan Wakely 2010-05-14 12:01:23 EDT
that's great - thanks!
Comment 9 Fedora Update System 2010-05-31 14:23:49 EDT
pstreams-devel-0.7.0-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2010-05-31 14:25:44 EDT
pstreams-devel-0.7.0-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.