Bug 591582 - [NV94] No sound from HDMI audio
[NV94] No sound from HDMI audio
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
16
All Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
[cat:performance]
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-12 11:48 EDT by Stefan Becker
Modified: 2013-02-15 08:56 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 19:40:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg logfile (79.09 KB, text/plain)
2010-05-12 11:49 EDT, Stefan Becker
no flags Details
X server logfile (414.36 KB, text/plain)
2010-05-12 11:50 EDT, Stefan Becker
no flags Details
mmiotrace for HDMI audio (12.65 MB, application/x-bzip-compressed-tar)
2010-05-13 06:11 EDT, Stefan Becker
no flags Details

  None (edit)
Description Stefan Becker 2010-05-12 11:48:29 EDT
Description of problem:

I'm not sure if HDMI Audio is already supposed to work with xorg-x11-drv-nouveau or if the functionality is actually in the kernel.

From user space everything looks OK: ALSA sees the HDMI audio device, PulseAudio shows it, nothing is muted, clients can send data to it and it seems to be processed correctly (timing feedback looks OK), the amplifier shows that HDMI audio is active. But in the end there is no audio coming out :-(


Version-Release number of selected component (if applicable):

kernel-2.6.33.3-85.fc13.x86_64
xorg-x11-server-Xorg-1.8.0-12.fc13.x86_64
xorg-x11-drv-nouveau-0.0.16-5.20100423git13c1043.fc13.x86_64
libdrm-2.4.20-1.fc13.x86_64
mesa-libGL-7.8.1-6.fc13.x86_64
alsa-lib-1.0.23-1.fc13.x86_64

How reproducible:
always

Additional info:
01:00.0 VGA compatible controller [0300]: nVidia Corporation G94 [GeForce 9800M GTS] [10de:062c] (rev a1)

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
...
card 0: Intel [HDA Intel], device 3: NVIDIA HDMI [NVIDIA HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
...

$ aplay -L
...
hdmi:CARD=Intel,DEV=0
    HDA Intel, NVIDIA HDMI
    HDMI Audio Output

$ pactl list
...
Sink #0
	State: SUSPENDED
	Name: alsa_output.pci-0000_00_1b.0.iec958-stereo
	Description: Internal Audio Digital Stereo (IEC958)
	Driver: module-alsa-card.c
	Sample Specification: s16le 2ch 44100Hz
	Channel Map: front-left,front-right
	Owner Module: 4
	Mute: no
	Volume: 0: 100% 1: 100%
	        0: 0.00 dB 1: 0.00 dB
	        balance 0.00
	Base Volume: 100%
	             0.00 dB
	Monitor Source: alsa_output.pci-0000_00_1b.0.iec958-stereo.monitor
	Latency: 0 usec, configured 0 usec
	Flags: HARDWARE DECIBEL_VOLUME LATENCY 
	Properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "ALC662 rev1 Digital"
		alsa.id = "ALC662 rev1 Digital"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "1"
		alsa.card = "0"
		alsa.card_name = "HDA Intel"
		alsa.long_card_name = "HDA Intel at 0xf4600000 irq 33"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1b.0"
		sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "293e"
		device.product.name = "82801I (ICH9 Family) HD Audio Controller"
		device.form_factor = "internal"
		device.string = "iec958:0"
		device.buffering.buffer_size = "352768"
		device.buffering.fragment_size = "176384"
		device.access_mode = "mmap+timer"
		device.profile.name = "iec958-stereo"
		device.profile.description = "Digital Stereo (IEC958)"
		device.description = "Internal Audio Digital Stereo (IEC958)"
		alsa.mixer_name = "Nvidia MCP78 HDMI"
		alsa.components = "HDA:10ec0662,15580860,00100101 HDA:10573055,00305557,00100900 HDA:10de0005,10de0101,00100000"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
...
	Profiles:
...
		output:hdmi-stereo: Digital Stereo (HDMI) Output (sinks: 1, sources: 0, priority. 5400)
		output:hdmi-stereo+input:analog-stereo: Digital Stereo (HDMI) Output + Analog Stereo Input (sinks: 1, sources: 1, priority. 5460)
...
Comment 1 Stefan Becker 2010-05-12 11:49:26 EDT
Created attachment 413464 [details]
dmesg logfile
Comment 2 Stefan Becker 2010-05-12 11:50:07 EDT
Created attachment 413465 [details]
X server logfile
Comment 3 Ben Skeggs 2010-05-12 19:09:25 EDT
Hey, thanks for the report.  Unfortunately it's not expected to work right now, no-one's even looked at what's required to support it as far as I know.

I guess it'd be handy to be able to see kmmio traces of the binary driver initialising HDMI audio, and one of it initialising a display *without* HDMI audio for comparison.  I know you've done this before, but the link is http://nouveau.freedesktop.org/wiki/MmioTrace, for reference :)
Comment 4 Stefan Becker 2010-05-13 06:11:38 EDT
Created attachment 413706 [details]
mmiotrace for HDMI audio

Here is what I got so far:

 - nvidia 195.36.24 driver works (AFAIR the last time I tried it didn't correctly work on this HW)
 - HDMI audio works with nvidia, so nothing else is broken
 - unfortunately both devices with HDMI input (amplifier, TV) support HDMI audio, so I can't generate a trace without HDMI audio

After installing kernel-debug and compiling the corresponding nvidia debug kernel module I was able to take the attached trace, following the instructions in mmiotrace.txt. I hope this gives you at least some information.
Comment 5 Stefan Becker 2010-05-14 04:26:56 EDT
FYI: kernel 2.6.34 added NVIDIA HDMI support in ALSA: <http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=25045705d4053925a617ed71c5e4b6888e468765>

But guessing from the code this doesn't apply for my chip, because it is only for NVIDIA HW with built-in HDMI audio codec (GT21x) and not for NVIDIA HW with SPDIF/HDMI input for HDMI Audio which is fed by the Intel HDA codec (an educated guess on my part).
Comment 6 Stefan Becker 2010-11-07 03:11:35 EST
Still doesn't work for F14. Tested with kernel-2.6.35.6-48.fc14.
Comment 7 Ben Skeggs 2010-11-07 18:01:46 EST
Yeah this is still expected.  I have patches in progress that have been tested and working on both the boards with SPDIF passthrough, and the boards with an onboard codec.

There's still some work to be done, and waiting on some core DRM changes to hit upstream before I'm able to commit them.  Once it's available, I'll take a shot a backporting them to F14.
Comment 8 Stefan Becker 2011-05-15 02:53:22 EDT
Retested with F15 Beta. Still doesn't work.

Version information:
kernel-2.6.38.6-26.rc1.fc15.x86_64
xorg-x11-server-Xorg-1.10.1-14.fc15.x86_64
xorg-x11-drv-nouveau-0.0.16-24.20110324git8378443.fc15.x86_64
libdrm-2.4.25-1.fc15.x86_64
mesa-libGL-7.11-0.9.20110509.0.fc15.x86_64
alsa-lib-1.0.24-2.fc15.x86_64
Comment 9 Stefan Becker 2011-11-13 06:45:16 EST
Code still missing in nouveau DRM driver. Moving to F16.

HDMI Audio support has been added in git HEAD for NVA3:NVD9 though.
Comment 10 Vladimir 2012-07-24 08:08:09 EDT
Notice the "nouveau.audio=1" at the end of the core team.
The result is unchanged: there is sound
Comment 11 Jurijs Kolomijecs 2012-09-27 01:57:04 EDT
The same issue with geForce 9400M on Acer Aspire.
Tried to play audio via HDMI in Fedora 18 alpha.
Comment 12 Fedora End Of Life 2013-01-16 16:58:36 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Fedora End Of Life 2013-02-13 19:40:30 EST
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.