Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 591610 - install can start in runlevel 5 without a X server
install can start in runlevel 5 without a X server
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity low
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
: Reopened
: 586443 (view as bug list)
Depends On: 588483
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-12 13:17 EDT by Bill Nottingham
Modified: 2014-03-16 23:23 EDT (History)
4 users (show)

See Also:
Fixed In Version: anaconda-13.21.40-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 588483
Environment:
Last Closed: 2010-07-02 16:49:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2010-05-12 13:17:09 EDT
+++ This bug was initially created as a clone of Bug #588483 +++

Description of problem:
Minimal+gnome installation doesn't install X server

Version-Release number of selected component (if applicable):
13 beta

How reproducible:


Steps to Reproduce:
1. Start install
2. Choose Minimal+Customise Now+Select Gnome
3. 
  
Actual results:
Reboot post install shows blank screen

Expected results:
Graphical login

Additional info:
Choosing minimal install then adding gnome with Customise Now fails to install an X server - this then means that the initial boot "fails" just leaving a blank screen.

In fact console logins are available if one switches VTs

I'd sort-of expect that gnome would depend on enough X to actually get a login screen presented on initial boot.

--- Additional comment from rstrode@redhat.com on 2010-05-04 12:33:32 EDT ---

What exactly did you click when you selected "Gnome" ?

There is no one GNOME package, and we don't have any groups called "GNOME" as far as I know (We have some desktop groups that will pull in GNOME though).

--- Additional comment from jkeating@redhat.com on 2010-05-04 12:52:29 EDT ---

This is by design.  The gnome desktop group includes the packages necessary to run gnome, but doesn't necessarily include packages to run it /locally/.  You can ssh in with forwarded X11 and run gnome on a remote X host.  In order to be able to run it locally, you must also select the Base X group.

--- Additional comment from paul@flinders.org on 2010-05-04 17:12:09 EDT ---

> What exactly did you click when you selected "Gnome" ?
Desktop environments, then Gnome (desktop) - but I think Jesse has a handle on what happened....

> This is by design

OK, but if you don't select the base X group the install apparently "fails" because the only thing you see on initial boot is a blank screen, not a console login.

It might be intentional but, to my mind at least, I /did/ expect minimal+"gnome desktop"to install just enough for a local graphical login plus a local gnome desktop.

--- Additional comment from herrold@owlriver.com on 2010-05-04 17:26:12 EDT ---

heh -- that would be Debian's: Suggests    ;)

--- Additional comment from jkeating@redhat.com on 2010-05-04 17:44:29 EDT ---

Getting nothing but a blank screen does indeed sound like a bug.  You should have been given the text login prompt.  If you can reproduce, please file that as a separate bug.

--- Additional comment from rstrode@redhat.com on 2010-05-04 21:42:13 EDT ---

Well there are potentially two bugs here:

1) anaconda puts runlevel 5 in inittab even when X server isn't installed (or maybe GDM doesn't Requires: Xorg ?)
2) Niche case of GNOME but-no-X is trumping slightly less niche case of "minimal GNOME install"

--- Additional comment from notting@redhat.com on 2010-05-05 11:44:37 EDT ---

anaconda sets runlevel 5 based on the presence of a display manager.

The display managers do not require the server.

--- Additional comment from rstrode@redhat.com on 2010-05-05 18:43:41 EDT ---

alright, so we've got to figure out whether the fix for 1) is:

- Make anaconda set runlevel 5 based on the presence of a display manager AND the presence of a X server
or
- Make GDM require X

If we go for the latter option we fix 2) as a side-effect

We could go for both, I suppose. CHRIS LUMENS do you have thoughts?

--- Additional comment from clumens@redhat.com on 2010-05-06 10:53:48 EDT ---

> - Make anaconda set runlevel 5 based on the presence of a display manager AND
> the presence of a X server

Are there valid reasons for running in runlevel 5 without having an X server installed?  Are there other programs that provide the same functionality as the X server that will require a broader test than just checking for xorg-x11-server (or whatever) in the transaction set?

Are there valid reasons for installing GDM but not an X server?

I'm fine with either fix, and I can see reasons for doing it both ways.

--- Additional comment from notting@redhat.com on 2010-05-06 12:30:32 EDT ---

IMO...

- runlevel 5 by default with X server *and* display manager == valid
- runlevel 5 by default with display manager only == invalid
- runlevel 5 by default with X server only == invalid

- install with X server and display manager == valid
- install with display manager only == valid (remote terminal/client server)
- install with X server only == valid, if sort of pointless.

--- Additional comment from clumens@redhat.com on 2010-05-11 17:19:31 EDT ---

> - runlevel 5 by default with X server *and* display manager == valid
> - runlevel 5 by default with display manager only == invalid
> - runlevel 5 by default with X server only == invalid
> 
> - install with X server and display manager == valid
> - install with display manager only == valid (remote terminal/client server)
> - install with X server only == valid, if sort of pointless.    

This sounds like you prefer an anaconda solution, then.

--- Additional comment from notting@redhat.com on 2010-05-11 18:08:55 EDT ---

Created an attachment (id=413275)
patch

Something like the attached, I suspect.

--- Additional comment from clumens@redhat.com on 2010-05-11 19:29:21 EDT ---

Looks reasonable to me.  Feel free to commit to master, or send to anaconda-devel-list if you really want to go crazy with the process.  But consider this my ACK.
Comment 1 RHEL Product and Program Management 2010-05-12 14:07:12 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Bill Nottingham 2010-05-13 16:57:04 EDT
*** Bug 586443 has been marked as a duplicate of this bug. ***
Comment 4 Alexander Todorov 2010-05-25 09:39:04 EDT
With anaconda-13.21.45-1.el6 (snapshot #5):

1) Minimal install + Desktop + X - boots into runlevel 5
2) Minimal install + Desktop only - boots into runlevel 3
3) Minimal install + X only - boots into runlevel 3
4) Minimal install only - boots into runlevel 3

Moving to VERIFIED.
Comment 5 releng-rhel@redhat.com 2010-07-02 16:49:17 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.