Bug 59162 - please upgrade to rsync 2.5.2
please upgrade to rsync 2.5.2
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: rsync (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-31 20:56 EST by Jamie Zawinski
Modified: 2014-03-16 22:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-31 20:56:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jamie Zawinski 2002-01-31 20:56:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.16-22 i686; Nav)

Description of problem:
Red Hat 7.2 comes with rsync 2.4.6-8.

Since upgrading to RH7.2, I've been periodically having
problems with corrupted files being uploaded, with the
error message:

<filename>
Warning: unexpected read size of 0 in map_ptr
Warning: unexpected read size of 0 in map_ptr


I upgraded to "rsync  version 2.5.2  protocol version 26"
from samba.anu.edu.au and the problem seems to have gone
away.

That site distributes RH RPMs of rsync, but only as
new as 2.4.6.  I had to build from source.

How reproducible: Sometimes
Steps to Reproduce: unclear.
Actual Results:  corrupted non-identical files.
Expected Results:  identical files, man.
Comment 1 Bill Nottingham 2002-01-31 21:24:03 EST
There's a 2.4.6-10 errata on the FTP site now; it replaces the (unfortunately)
broken 2.4.6-8 errata.

Note You need to log in before you can comment on or make changes to this bug.