This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 591622 - ModemManager will not release itself when a 3G connection is closed
ModemManager will not release itself when a 3G connection is closed
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ModemManager (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-12 13:45 EDT by David Batson
Modified: 2011-02-02 04:46 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-02 04:46:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Batson 2010-05-12 13:45:14 EDT
Description of problem:
NetworkManager is not releasing itself when my 3G connection is closed - either by choice or from loss of signal.  This prevents other programs such as minicom and pccardctl from working as expected.

Version-Release number of selected component (if applicable):
NetworkManager 0.8

How reproducible:
If I boot F12 and open a terminal as root, I can use minicom to change the configuration of my Sierra Wireless 881 AirCard 3G modem.  As I type my characters are echoed as I expect.

If I boot F12 and open a terminal as root, I can use 'pccardctl eject' and 'pccardctl insert' with my Sierra Wireless 881 AirCard 3G modem, no problem.

If I boot F12 and connect my Sierra Wireless 881 AirCard 3G modem to the internet, then subsequently disconnect (either by choice or because I lost the cellular signal), (1) minicom will not echo characters if I start it in terminal, (2) using 'pccardctl eject' hangs terminal and 'pccardctl insert' will not reenable my Sierra Wireless 881 AirCard 3G modem.

A third problem is that even though I set my 3G modem to use 2G only using minicom, NetworkManager resets the modem to automatic.  I do not have this problem in Mandriva 2010 using kppp (I do not have kppp installed in F12 Gnome).


Steps to Reproduce:
1.Boot F12 and choose Connect to AT&T Broadband (3G) from NetworkManager
2.Choose disconnect AT&T Broadband from NetworkManager
3.Open terminal as root and run either minicom or 'pccardctl eject'/'pccardctl insert'.
  
Actual results:
NetworkManager does not release device when the internet connection is disconnected.

Expected results:
NetworkManager to release device when no internet connection is active.

Additional info:
Using F12 with all the current updates.
Comment 1 Dan Williams 2010-05-12 15:26:46 EDT
You'll want to uncheck the "Enable WWAN" box in the nm-applet menu, which causes ModemManager to close the WWAN device ports.  These ports are normally open during and after a connection so that you can see the device's signal strength, roaming status, and access technology which helps you make the decision of whether or not to connect to the network in the first place.  Allow at least 5 seconds for the ports to be closed before trying minicom.

If this doesn't work, please re-open and we can do some more debugging.  Thanks!
Comment 2 David Batson 2010-05-12 20:02:19 EDT
The NetworkManager "Enable WWAN" box was always unchecked.  Actually that box is labeled: "Enable Mobile Broadband".  That is not the problem.  BTW, I do NOT have the WWAN connection set up to "Connect Automatically" either.

After going into terminal and closing NetworkManager, I still could not properly use minicom.  However after going into terminal and closing modem-manager (NetworkManager was still closed), the port was freed and minicom would work properly.

I changed the Component in this bug report from NetworkManager to ModemManager.  I don't seem to be able to reopen the bug.
Comment 3 David Batson 2010-05-12 20:13:32 EDT
Version-Release number of selected component (if applicable):
ModemManager-0.3-9.git20100409.fc12.i686
Comment 4 Dan Williams 2010-05-17 20:08:14 EDT
(In reply to comment #0)
> Description of problem:
> NetworkManager is not releasing itself when my 3G connection is closed - either
> by choice or from loss of signal.  This prevents other programs such as minicom
> and pccardctl from working as expected.
> 
> Version-Release number of selected component (if applicable):
> NetworkManager 0.8
> 
> How reproducible:
> If I boot F12 and open a terminal as root, I can use minicom to change the
> configuration of my Sierra Wireless 881 AirCard 3G modem.  As I type my
> characters are echoed as I expect.

What configuration are you changing?  The 2G/3G preference?

> If I boot F12 and open a terminal as root, I can use 'pccardctl eject' and
> 'pccardctl insert' with my Sierra Wireless 881 AirCard 3G modem, no problem.

There shouldn't be any need to use pccardctl; is there some reason you're using that command?  The 881 is a CardBus card and hotplug works fine.  

> If I boot F12 and connect my Sierra Wireless 881 AirCard 3G modem to the
> internet, then subsequently disconnect (either by choice or because I lost the
> cellular signal), (1) minicom will not echo characters if I start it in
> terminal, (2) using 'pccardctl eject' hangs terminal and 'pccardctl insert'
> will not reenable my Sierra Wireless 881 AirCard 3G modem.

Are you using NetworkManager to connect/disconnect?  If so, when you disconnect, it's expected that ModemManager still keeps the port open (for signal quality, roaming status, and access technology) until you *un*check "Enable mobile broadband" in the nm-applet menu.

ModemManager does not release the device when the actual internet connection goes down because it's useful to see the things above (signal strength, access technology, roaming status, etc) even when you're disconnected.  You can use the "Enable mobile broadband" item in the nm-applet menu to control whether modem-manager keeps the port open or not.

> A third problem is that even though I set my 3G modem to use 2G only using
> minicom, NetworkManager resets the modem to automatic.  I do not have this
> problem in Mandriva 2010 using kppp (I do not have kppp installed in F12
> Gnome).

You can change the 2G/3G preference of your connection using the connection editor and when you connect ModemManager will use that information and set the modem to 2G/3G as you've specified for you.

You'll want to use the latest NM/MM updates though:

su -c 'yum --enablerepo=updates-testing update NetworkManager ModemManager'

which have that capability.  Earlier versions (including your 2010-04-08) version don't have that feature.

Let me know if this works for you.
Comment 5 David Batson 2010-05-18 06:40:53 EDT
I installed the update from testing that you list above.

Are you using NetworkManager to connect/disconnect?  If so, when you
disconnect, it's expected that ModemManager still keeps the port open (for
signal quality, roaming status, and access technology) until you *un*check
"Enable mobile broadband" in the nm-applet menu.

ModemManager does not release the device when the actual internet connection
goes down because it's useful to see the things above (signal strength, access
technology, roaming status, etc) even when you're disconnected.  You can use
the "Enable mobile broadband" item in the nm-applet menu to control whether
modem-manager keeps the port open or not.

Yes, I use NetworkManager to connect/disconnect.  The box "Enable mobile broadband" is not, and had never been checked.  If I close the connection manually or it is closed by the carrier (it happens), modem-manager does not close itself.  I cannot run minicom or pccardctl properly unless I close modem-manager from terminal with 'killall modem-manager'.  Then to be able to connect again with NetworkManager I have to start modem-manager again from terminal.

I never noticed the "signal quality" indicator before with the connection down because I never had "Enable mobile broadband" checked.  Trying it just now with it checked, I do see the signal strength indication with the connection down.

You can change the 2G/3G preference of your connection using the connection
editor and when you connect ModemManager will use that information and set the
modem to 2G/3G as you've specified for you.

I didn't know about that option, but now I see it.  Thanks.

To reitterate, unchecking "Enable mobile broadband" and closing the connection does not release modem-manager.  I think that it should.
Comment 6 David Batson 2010-05-18 06:44:06 EDT
Sorry, I thought that what I quoted from you would stand out when I posted my last comment.
Comment 7 Dan Williams 2010-05-20 02:55:24 EDT
Nah, you have to hit 'reply' to get that and then leave the ">" characters in.

Ok, so what you're saying is that when you successfully connect to the cellular network using NetworkManager, the "Enabled Mobile Broadband" box is *not* checked?  When connected, that box should be checked; if not there's a bug.  Then, when you *un*check that box, modem-manager should release the port.
Comment 8 David Batson 2010-05-20 06:04:19 EDT
(In reply to comment #7)

> Ok, so what you're saying is that when you successfully connect to the cellular
> network using NetworkManager, the "Enabled Mobile Broadband" box is *not*
> checked?  When connected, that box should be checked; if not there's a bug. 
> Then, when you *un*check that box, modem-manager should release the port.    

That is correct. When I connect using NetworkManager, the "Enable Mobile Broadband" box does not become checked upon connection.  It remains unchecked.  I can check/uncheck it after the fact if I want.
Comment 9 Dan Williams 2010-05-24 20:10:04 EDT
Enable checkbox state fixed upstream:

2e92d84ef027d4aa1cf1edb628db771ccfda2d23 (master)
d103bfd99ed4e660fc0a375410e29e15f6029c12 (0.8.x)
Comment 10 David Batson 2010-06-14 11:24:09 EDT
I just got a more recent version of NetworkManager/ModemManager from System Update last night, but the problem remains in F13.

Here is what is currently installed:

NetworkManager-0.8.1-0.1.git20100510.fc13.i686
NetworkManager-openvpn-0.7.997-1.fc13.i686
NetworkManager-glib-0.8.1-0.1.git20100510.fc13.i686
NetworkManager-openconnect-0.8.0-1.git20100411.fc13.i686
NetworkManager-pptp-0.8.0-1.git20100411.fc13.i686
NetworkManager-vpnc-0.8.0-1.git20100411.fc13.i686
NetworkManager-gnome-0.8.1-0.1.git20100510.fc13.i686

ModemManager-0.3-13.git20100507.fc13.i686
Comment 11 Vikas 2011-01-16 01:12:14 EST
Has this been fixed in latest version?
Any Update on this ???
Comment 12 Jirka Klimes 2011-02-02 04:46:48 EST
The fix from comment 9 is in both F13 and F14 updates.

Note You need to log in before you can comment on or make changes to this bug.