Bug 591624 - [abrt] crash in ghostscript-8.71-6.fc12: gs_closedevice: Process /usr/bin/gs was killed by signal 11 (SIGSEGV)
[abrt] crash in ghostscript-8.71-6.fc12: gs_closedevice: Process /usr/bin/gs ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:dc98bcbf88fe4f1e2e9302235d1...
:
: 630118 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-12 13:49 EDT by Przemek Klosowski
Modified: 2010-10-14 19:01 EDT (History)
2 users (show)

See Also:
Fixed In Version: ghostscript-8.71-16.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-11 15:25:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (5.87 KB, text/plain)
2010-05-12 13:49 EDT, Przemek Klosowski
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Ghostscript 691296 None None None Never

  None (edit)
Description Przemek Klosowski 2010-05-12 13:49:11 EDT
abrt 1.0.9 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: gs Download/slyt394a.pdf
comment: evince doesn't crash, but doesn't display anything either
component: ghostscript
crash_function: gs_closedevice
executable: /usr/bin/gs
global_uuid: dc98bcbf88fe4f1e2e9302235d10cf391efe4b83
kernel: 2.6.31.12-174.2.22.fc12.i686.PAE
package: ghostscript-8.71-6.fc12
rating: 4
reason: Process /usr/bin/gs was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. retrieve Texas Instruments PDF document http://www.ti.com/ww/en/analog/led/slyt394a.pdf
2. gs slyt394a.pdf
3. press return to get past the first page which complains about PDF errors (heh, the file was created by Adobe and it still allegedly doesn't follow PDF standards)
Comment 1 Przemek Klosowski 2010-05-12 13:49:12 EDT
Created attachment 413504 [details]
File: backtrace
Comment 2 Tim Waugh 2010-05-13 11:58:39 EDT
Confirmed.  This is a regression since 8.70.
Comment 3 Tim Waugh 2010-05-13 12:09:38 EDT
Reported upstream with patch.
Comment 4 Tim Waugh 2010-08-20 07:41:04 EDT
*** Bug 625671 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2010-09-03 10:05:57 EDT
ghostscript-8.71-15.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/ghostscript-8.71-15.fc12
Comment 6 Fedora Update System 2010-09-03 10:06:48 EDT
ghostscript-8.71-14.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/ghostscript-8.71-14.fc13
Comment 7 Fedora Update System 2010-09-03 10:07:51 EDT
ghostscript-8.71-15.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/ghostscript-8.71-15.fc14
Comment 8 Fedora Update System 2010-09-03 12:43:50 EDT
ghostscript-8.71-15.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ghostscript'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/ghostscript-8.71-15.fc14
Comment 9 Przemek Klosowski 2010-09-03 14:24:09 EDT
The good news is that ghostscript-8.71-14.fc13 does not crash, but it goes in an infinite loop on the same file http://www.ti.com/ww/en/analog/led/slyt394a.pdf

Error: read error: passed the end of the codestream (start = 162502800, current = 162788695, end = 162788695

Error: read error: passed the end of the codestream (start = 162502800, current = 162788695, end = 162788695

Error: read error: passed the end of the codestream (start = 162502800, current = 162788695, end = 162788695

... repeated ad infinitum.
Comment 10 Tim Waugh 2010-09-04 06:55:28 EDT
(In reply to comment #6)
> ghostscript-8.71-14.fc13 has been submitted as an update for Fedora 13.
> https://admin.fedoraproject.org/updates/ghostscript-8.71-14.fc13

This was submitted in error -- please try ghostscript-8.71-15.fc13 instead.
Comment 11 Tim Waugh 2010-09-13 12:05:30 EDT
Oh dear, ghostscript-8.71-15.fc13 is bad as well.

New package coming up...
Comment 12 Fedora Update System 2010-09-13 12:52:05 EDT
ghostscript-8.71-16.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/ghostscript-8.71-16.fc14
Comment 13 Fedora Update System 2010-09-13 12:55:16 EDT
ghostscript-8.71-16.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/ghostscript-8.71-16.fc13
Comment 14 Fedora Update System 2010-09-13 12:56:50 EDT
ghostscript-8.71-16.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/ghostscript-8.71-16.fc12
Comment 15 Tim Waugh 2010-09-13 13:13:51 EDT
*** Bug 630118 has been marked as a duplicate of this bug. ***
Comment 16 Fedora Update System 2010-10-11 15:25:21 EDT
ghostscript-8.71-16.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2010-10-11 23:13:01 EDT
ghostscript-8.71-16.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2010-10-14 19:01:20 EDT
ghostscript-8.71-16.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.