Bug 591636 - libsane-hpaio should be required by hplip-gui
Summary: libsane-hpaio should be required by hplip-gui
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: hplip
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Tim Waugh
QA Contact: Yulia Kopkova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-12 18:19 UTC by Issue Tracker
Modified: 2018-11-14 19:31 UTC (History)
6 users (show)

Fixed In Version: hplip-3.9.8-31.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-10 20:38:29 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Issue Tracker 2010-05-12 18:19:11 UTC
Escalated to Bugzilla from IssueTracker

Comment 1 Issue Tracker 2010-05-12 18:19:12 UTC
Event posted on 05-12-2010 02:01pm EDT by woodard

Description of problem:
After setting up the OfficeJet with the hplip-gui. Trying to run xsane or scanimage gives this error message.

[ben@snog ~]$ scanimage -d hpaio:/net/Officejet_Pro_8500_A909g?ip=192.168.1.105
scanimage: open of device hpaio:/net/Officejet_Pro_8500_A909g?ip=192.168.1.105 failed: Invalid argument

How reproducible:
always 

Steps to Reproduce:
make sure that you don't have the libsane-hpaio rpm installed and setup the printer using hplip-gui then try to scan.

Actual results:
it fails with that invalid argument message

Expected results:
it works.

Additional info:
the problem is that you need the libsane-hpaio rpm to be installed. Maybe it should be a dependency for hplip-gui? At the very least those programs should have a much better error message as to why they failed.

Installing the libsane-hpaio fixes the problem
This event sent from IssueTracker by tgummels  [LLNL (desktop)]
 issue 882503

Comment 2 RHEL Program Management 2010-05-12 19:28:20 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Tim Waugh 2010-05-13 14:31:14 UTC
Agreed, this should be added as a dependency.  Thanks!

Comment 4 Jiri Popelka 2010-06-07 16:22:05 UTC
Fixed in hplip-3.9.8-31.el6
http://post-office.corp.redhat.com/archives/cvs-commits-list/2010-June/msg00914.html

Comment 7 releng-rhel@redhat.com 2010-11-10 20:38:29 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.