Bug 591637 - After using computer for a while, EVERYTHING starts to segfault.
After using computer for a while, EVERYTHING starts to segfault.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
13
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Andreas Schwab
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-12 14:25 EDT by Cesko Voeten
Modified: 2010-06-10 08:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-10 08:13:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
part of /var/log/messages showing the segfaults (26.23 KB, text/plain)
2010-05-12 14:25 EDT, Cesko Voeten
no flags Details
The trace abrt provided of the first program in its list. (36.09 KB, text/plain)
2010-05-12 14:27 EDT, Cesko Voeten
no flags Details
rpm -qa --last (85.58 KB, text/plain)
2010-05-14 09:07 EDT, Cesko Voeten
no flags Details

  None (edit)
Description Cesko Voeten 2010-05-12 14:25:59 EDT
Created attachment 413515 [details]
part of /var/log/messages showing the segfaults

Description of problem:
Whenever my computer has been on for a number of hours (3 or 4 in this case), ALL programs (and I really do mean ALL, except for the most basic programs such as cat or dmesg) suddenly start to segfault upon launch. Some programs also crash even though they have already been running for a while, but this is sporadic, the only sure way to get a program to crash is to launch a new instance of it.
I know this probably sounds really strange to you, but I can't describe it any better - when I launch a program from terminal it just says "Segmentation fault".

Version-Release number of selected component (if applicable):
13, latest updates applied.

How reproducible:
I've had this for a while now, the first two or three times I thought it was just a glitch, but now I'm absolutely sure this is a bug in Fedora.

Steps to Reproduce:
I don't know. But it USUALLY (but far from always) happens when the computer has been running for a long time. It seems to happen more often if I have played fullscreen games.
  
Actual results:
EVERY program segfaults the second it's started.

Expected results:
. . .

Additional info:
I really don't know how to be helpful on this, but I have collected:
 - relevant part from /var/log/messages
 - the first of 8 or so crashes in abrt's list after rebooting
I do not know what all these apps have in common, but dmesg said ld-2.12.so and according to yum that belongs to glibc.
Comment 1 Cesko Voeten 2010-05-12 14:27:57 EDT
Created attachment 413516 [details]
The trace abrt provided of the first program in its list.
Comment 2 Andreas Schwab 2010-05-14 04:16:13 EDT
What are the latest updated packages?
Comment 3 Cesko Voeten 2010-05-14 05:36:09 EDT
Do you mean this?


glibc.i686                             2.12-1                            @fedora
glibc-common.i686                      2.12-1                            @fedora
glibc-devel.i686                       2.12-1                            @fedora
glibc-headers.i686                     2.12-1                            @fedora
Comment 4 Andreas Schwab 2010-05-14 07:46:13 EDT
rpm -qa --last
Comment 5 Cesko Voeten 2010-05-14 09:07:37 EDT
Created attachment 414045 [details]
rpm -qa --last
Comment 6 Andreas Schwab 2010-05-14 11:52:51 EDT
Does prelink -au help?
Comment 7 Cesko Voeten 2010-05-14 13:13:17 EDT
I can't say with certainty, as I don't know what conditions trigger this problem. But it seemed to happen more often after playing fullscreen games, and I just played SuperTux for half an hour and the system was still stable afterwards. So it looks like it did help. I'll report back to you if I notice my system going south again.
Comment 8 Andreas Schwab 2010-06-10 08:13:32 EDT
This is unlikely to be a software problem.

Note You need to log in before you can comment on or make changes to this bug.