Bug 59164 - AS1200/AS4100 crash during kernel boot
Summary: AS1200/AS4100 crash during kernel boot
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.3
Hardware: alpha Linux
medium
high
Target Milestone: ---
Assignee: Beth Uptagrafft
QA Contact: Beth Uptagrafft
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-01 03:22 UTC by harry.heinisch
Modified: 2007-04-18 16:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-01 17:08:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for arch/alpha/kernel/core_mcpcia.c to fix AS4100/AS1200 crashes (1.31 KB, patch)
2002-02-01 03:23 UTC, harry.heinisch
no flags Details | Diff

Description harry.heinisch 2002-02-01 03:22:01 UTC
Description of Problem:

The BOOT kernel crashes during startup on AS1200 and AS4100, making
installation impossible.


Version-Release number of selected component (if applicable): alpha-7.2-beta1


How Reproducible:

Always


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:

During boot of the BOOT kernel off the CD, the 2.4.9-14a kernel incorrectly
probes and sets up the PCI bus devices' resources, leaving some devices
incorrectly initialized. Most often this shows up as an infinite loop of
SCSI error messages, since it is often the case that the SCSI controller
is one of the devices incorrectly initialized.


Expected Results:

Correct operation, of course... :-)

Additional Information:
	
This is not just a 2.4.9-14a kernel problem; it exists in 2.4.17 as well.

The bug may be exacerbated by the types of devices present; the test machine
on which I had the severe problems had a KZPCM (dual SCSI plus NIC combo
board) on each of the 2 peer PCI buses.

I have a patch that fixes the problems, which I will attach later. (JAE)

Comment 1 harry.heinisch 2002-02-01 03:23:56 UTC
Created attachment 44216 [details]
patch for arch/alpha/kernel/core_mcpcia.c to fix AS4100/AS1200 crashes

Comment 2 Beth Uptagrafft 2002-02-04 20:15:00 UTC
These systems are outside the scope of the contract and will be marked CLOSED - 
WONTFIX.

Comment 3 john.goshdigian 2002-03-01 17:08:10 UTC
The patch is supplied, it is important that this server, which worked with 7.1
release, continue to work. We are not asking for you to do any extra testing,
simply include the fix, so the AS1200 and AS4100 systems can install 7.2



Comment 4 Phil Copeland 2002-04-03 22:19:57 UTC
Fixed and working. (ok works on Elliots 4100)...

Closed.


Note You need to log in before you can comment on or make changes to this bug.