Bug 591644 - The kernel module for dm-multipath is not loaded in 6.0-20100511.3
Summary: The kernel module for dm-multipath is not loaded in 6.0-20100511.3
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: device-mapper-multipath   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: beta
: ---
Assignee: Ben Marzinski
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Keywords: TestBlocker
Depends On:
Blocks: 596804
TreeView+ depends on / blocked
 
Reported: 2010-05-12 18:41 UTC by Barry Donahue
Modified: 2010-07-02 18:58 UTC (History)
17 users (show)

Fixed In Version: device-mapper-multipath-0.4.9-21.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 596804 (view as bug list)
Environment:
Last Closed: 2010-07-02 18:58:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the kickstart file for the install. (1.72 KB, text/plain)
2010-05-27 12:41 UTC, Barry Donahue
no flags Details

Description Barry Donahue 2010-05-12 18:41:03 UTC
Description of problem: After installing the latest release the kernel module for multipath is not loaded.


Version-Release number of selected component (if applicable):
kernel 2.6.32-25.el6.x86_64
device-mapper-multipath-0.4.9-19.el6.x86_64

How reproducible: every install.


Steps to Reproduce:
1.
2.
3.
  
Actual results:

   If you run any multipath command you get this error:
# multipath -ll
May 12 10:40:06 | DM multipath kernel driver not loaded



Expected results:


Additional info:

Comment 2 Ben Marzinski 2010-05-13 01:33:07 UTC
This is happening because anaconda doesn't create /etc/multipath.conf by default, and without it, the multipath modules isn't installed.  You can create a multipath.conf file by running

# mpathconf --enable

Unfortunately, multipath doesn't tell you that there is no config file if the kernel module isn't loaded. Also, mpathconf --enable doesn't load the module (or chkconfig multipathd on and start the daemon).  All these things need to happen. Then you will get a helpful error message telling you to run mpathconf, and when you do, multipath will be working correctly.

Comment 4 Peter Jones 2010-05-25 17:33:27 UTC
This should be fixed in anaconda-13.21.40-1 , which is in snap 5.  Please test and verify.

Comment 5 Barry Donahue 2010-05-25 18:54:03 UTC
I just installed nfs --server=storage.bos.redhat.com --dir=/vol/engineering/devarchive/redhat/rel-eng/RHEL6.0-Snapshot-5/6.0/Server/x86_64/os

   I still get the same error.

# multipath -ll
May 25 15:03:00 | DM multipath kernel driver not loaded

Comment 6 Ben Marzinski 2010-05-25 20:03:23 UTC
device-mapper-multipath-0.4.9-21.el6 changed the code around so that it will instruct you to run mpathconf. Running

# mpathconf --enable

will give you a default configuration file, if you don't have any, and it will load the module, and chkconfig multipathd on.  If you do

# mpathconf --enable --with_multipathd

It will also start multipathd immediately.  If you don't need to modify the default configuration file, this is the way to go. Otherwise, after running mpathconf, you should edit the file to your liking, and then run

# service multipathd start

Comment 7 Peter Jones 2010-05-26 21:30:17 UTC
Barry, can you attach your ks.cfg ?

Comment 8 Barry Donahue 2010-05-27 12:41:18 UTC
Created attachment 417225 [details]
This is the kickstart file for the install.

Comment 9 Ben Marzinski 2010-05-27 14:54:50 UTC
Since this bug was opened against device-mapper-multipath, and the change for that has been committed, I've cloned a bug to be used for the anaconda fixes.  The new bugzilla is #596804

Comment 12 releng-rhel@redhat.com 2010-07-02 18:58:04 UTC
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.