Bug 59165 - DS20 with more than 2GB of memory crashes during install
DS20 with more than 2GB of memory crashes during install
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
alpha Linux
high Severity high
: ---
: ---
Assigned To: Diego Novillo
Beth Uptagrafft
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-31 22:32 EST by harry.heinisch
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-11 15:17:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for arch/alpha/kernel/pci.c to fix quirk_cypress() bug (601 bytes, patch)
2002-01-31 22:34 EST, harry.heinisch
no flags Details | Diff

  None (edit)
Description harry.heinisch 2002-01-31 22:32:59 EST
Description of Problem:

On a DS20E with more than 2GB of memory and SCSI controller on PCI bus #0,
the install crashes.


Version-Release number of selected component (if applicable): alpha-7.2-beta1


How Reproducible:

Always, but not exactly the same symptoms.


Steps to Reproduce:
1. DS20 or DS20E with more than 2GB of memory
2. SCSI controller (doesn't matter what kind) on PCI bus #0
3. full ("Everything") install

Actual Results:

During the install, the kernel will crash with various symptoms, sometimes
a panic, sometimes just a complete hung machine.


Expected Results:

Flawless install, of course... :-)


Additional Information:

The bug is caused by a flawed workaround for a CYPRESS chipset limitation.
The workaround attempts to adjust a resource if it finds more than 2GB of
memory, and incorrectly calculates the adjustment.

I will attach a bugfix for this problem. (JAE)
Comment 1 harry.heinisch 2002-01-31 22:34:40 EST
Created attachment 44217 [details]
patch for arch/alpha/kernel/pci.c to fix quirk_cypress() bug
Comment 2 Beth Uptagrafft 2002-02-01 15:20:44 EST
Does this happen on a DS20E with exactly 2GB memory?  That's what our system 
has.
Comment 3 Jeff Wiedemeier 2002-02-02 21:20:45 EST
With a 2.4.9 kernel, this will not happen with exactly 2GB of memory - more 
than 2GB is required to encounter this bug (DS20 / DS20E support up to 4GB of 
memory).
Comment 4 Diego Novillo 2002-02-06 15:17:07 EST
The patch has been added to the kernel for the upcoming release.
Comment 5 Beth Uptagrafft 2002-03-13 09:50:05 EST
I'm closing this bug because it was fixed in the Feb 22 release.

Note You need to log in before you can comment on or make changes to this bug.