Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 591670 - Bad texture format for windows in gnome-shell
Bad texture format for windows in gnome-shell
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
13
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-12 15:41 EDT by Alastair Neil
Modified: 2010-10-10 19:45 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-10 19:45:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screwed up test and buttons (348.51 KB, image/png)
2010-09-10 20:19 EDT, Kenny Armstrong
no flags Details

  None (edit)
Description Alastair Neil 2010-05-12 15:41:10 EDT
Description of problem:
applications have an over-bright washed out appearance, extremely unpleasant to use for any more than a few minutes at a time.

Version-Release number of selected component (if applicable):
mesa-dri-drivers-experimental-7.8.1-6.fc13.x86_64
xorg-x11-drv-nouveau-0.0.16-5.20100423git13c1043.fc13.x86_64
gnome-shell-2.29.1-4.x86_64

How reproducible:
always

Steps to Reproduce:
1.enable gnome-shell
2.put on dark glasses
3.brace for eye strain
  
Actual results:
over-bright poor contrast applications

Expected results:
normal appearance - no different from under compiz.


Additional info:

The only app that is unaffected is gnome-terminal, however only the main window is unaffected all the dialogs are affected by the problem.
Comment 1 Owen Taylor 2010-05-12 16:02:47 EDT
This is using the Nouveau 3D support from mesa-drivers-experimental, right?
Comment 2 Alastair Neil 2010-05-21 01:21:57 EDT
(In reply to comment #1)
> This is using the Nouveau 3D support from mesa-drivers-experimental, right?    

(In reply to comment #1)
> This is using the Nouveau 3D support from mesa-drivers-experimental, right?    

Yes

mesa-dri-drivers-experimental-7.8.1-6.fc13.x86_64
Comment 3 Owen Taylor 2010-05-21 12:42:17 EDT
Nouveau 3D problem with texture from pixmap textures for windows without an alpha channel. Assigning to the DDX driver though as likely or more likely to be a Mesa problem.
Comment 4 Fabien Archambault 2010-06-18 03:38:34 EDT
Same problem here. Even with an icc dedicated to the screen the colors are too bright in gnome-shell so it is unusable.
Comment 5 Kenny Armstrong 2010-09-10 20:19:42 EDT
Created attachment 446613 [details]
screwed up test and buttons
Comment 6 Kenny Armstrong 2010-09-10 20:20:41 EDT
I am having the same problems here.  Fedora 13, not modifications, just newest nouveau driver and experimental 3d driver.
Comment 7 Gregor Hlawacek 2010-10-10 13:54:03 EDT
This still exists :-(
Comment 8 Bruce Cowan 2010-10-10 14:54:48 EDT
I've found that this no longer happens with Fedora 14 with a 9800 GT.
Comment 9 Ben Skeggs 2010-10-10 19:45:58 EDT
Ok, this isn't going to be fixed in F13.  The numerous changes to the nouveau 3D drivers since F13 aren't easily backported and would require changes to other parts of the Mesa stack and potentially regress other drivers too.

However, as mentioned, F14 should work OK, and if not, these issues will be fixed there instead.

Note You need to log in before you can comment on or make changes to this bug.