Bug 591689 - spamassassin RPM is missing dependency for perl-Mail-SPF
spamassassin RPM is missing dependency for perl-Mail-SPF
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: spamassassin (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Nick Bebout
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-12 16:19 EDT by mec74mer
Modified: 2010-06-06 21:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-06 21:58:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mec74mer 2010-05-12 16:19:57 EDT
Description of problem:
The default configuration for spamassassin is to enable SPF (/etc/mail/spamassassin/init.pre includes the line "loadplugin Mail::SpamAssassin::Plugin::SPF.)  The SPF plugin uses the perl module Mail::SPF (or the outdated Mail::SPF::Query which I don't care about.)  See the perldoc for Mail::SpamAssassin::Plugin::SPF.

Mail::SPF is included in the perl-Mail-SPF RPM.  Mail::SPF is not included in the spamassassin RPM.  The problem is that perl-Mail-SPF is not a dependency in the spamassassin RPM (per "rpm -q --requires spamassassin".)

Because of this problem, SPF tests are not performed by spamassassin even though init.pre looks like it is loading the SPF plugin.

Version-Release number of selected component (if applicable):
spamassassin-3.3.1-2.fc12.i686

How reproducible:
This problem is easily reproducible.

Steps to Reproduce:
1. yum install spamassassin
2. spamassassin --debug --lint
3. 
  
Actual results:
There is an error message that Mail::SPF is required but could not be found.  (Sorry, I don't have the exact message because my machine has Mail::SPF installed.)

Expected results:
May 12 15:13:55.936 [20615] dbg: diag: [...] module installed: Mail::SPF, version v2.006

Additional info:
I guess there are at least two ways to fix this problem.  One way is to not load the SPF plugin in spamassassin.  With this approach, it is up to the use to figure out that they need to load Mail::SPF if they want to load the plugin.  The second way is to include perl-Mail-SPF as a dependency in the spamassassin RPM.
Comment 1 Kevin Fenzi 2010-05-28 18:12:11 EDT
I'm open to either solution here. The dep is pretty small, and it does add some functionality, but it's not really needed to run. 

Can the co-maintainers all chime in here? Thoughts?
Comment 2 Nick Bebout 2010-06-02 10:27:36 EDT
I'm open to either solution, but I'd personally rather see us just add perl-Mail-SPF as a dependency.
Comment 3 Nick Bebout 2010-06-06 21:58:36 EDT
I've added perl(Mail::SPF) as a dependency, and built it for F-11 F-12 and F-13, but I'm not pushing updates at the moment just for this, but they are available in koji if you want to download them.  They will be pushed along with the next update we do.

Note You need to log in before you can comment on or make changes to this bug.