Bug 591709 - udev takes almost 100% CPU due to xorg (intel) continuously re-initializing displays
Summary: udev takes almost 100% CPU due to xorg (intel) continuously re-initializing d...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
medium
high
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard: card_GM45
Keywords: Patch, Reopened, Triaged
Depends On: udev-intel-flood
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-12 21:02 UTC by Matěj Cepl
Modified: 2010-11-15 14:17 UTC (History)
10 users (show)

Fixed In Version: 2.6.32-52.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: udev-intel-flood
Environment:
Last Closed: 2010-11-15 14:17:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Comment 2 RHEL Product and Program Management 2010-05-12 23:18:57 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Adam Jackson 2010-05-24 14:18:18 UTC
So the deal here is that we're enabling output hotplug interrupts on more outputs than we perhaps should, because Intel hardware doesn't give us an especially reliable connector table.  So we get status change events for outputs that aren't actually there.

There may also be a secondary bug where we _keep_ getting these events, triggered by the output rescan itself.

Getting the hardware would be an important first step here.

Comment 4 Adam Jackson 2010-05-24 16:58:25 UTC
alternatively, anyone who can reproduce this, please boot with drm.debug=0x0f and attach dmesg from the resulting udev storm.

Comment 5 Adam Jackson 2010-07-01 14:28:26 UTC
There's been some motion on this upstream, some patches that resolve it for some people but not for others.  I've got a couple in mind that I can backport, but it's hard to say whether they'll fix the issue completely.

Comment 7 Matěj Cepl 2010-07-15 09:37:34 UTC
Just to emphasize I cannot reproduce this bug anymore, I haven't seen this for couple of months with RHEL-6. However, given its heavy hardware dependency I wouldn't close this as fixed.

Comment 9 Christopher Aillon 2010-07-15 20:51:47 UTC
Closing based on reporter's comments in comment 7.  Reopen if still exists.

Comment 10 Adam Jackson 2010-07-16 15:27:52 UTC
Reopening, I still have changes pending for this.

Comment 11 Adam Jackson 2010-07-16 19:02:29 UTC
Patch posted

Comment 12 Cameron Meadors 2010-07-19 19:07:55 UTC
What hardware is actually affected by this?  I only found mention of the MSI-GT725 in the fedora.  Are there other laptops that exhibit this bug? Is this maybe somthing that only depends on what graphics card you have?  or is it the whole package and how the graphics is integrated into the system?

Comment 13 Dave Airlie 2010-07-21 01:32:57 UTC
its a whole package type of thing, though I think any of the T500/W500 should be able to reproduce. I think I reproduced on a W500 at one point.

Comment 16 Aristeu Rozanski 2010-07-26 15:16:43 UTC
Patch(es) available on kernel-2.6.32-52.el6

Comment 21 James Laska 2010-09-01 18:44:14 UTC
I tested this bug on a t500 borrowed from helpdesk.  I'm unable to reproduce any udev issues when coming out of suspend.  Both suspend+resume work beautifully on this laptop.  Considering I wasn't able to reproduce the reported problem, I'm marking this issue as verified:SanityOnly.

Comment 22 releng-rhel@redhat.com 2010-11-15 14:17:05 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.