Bug 591720 - [gm45] resuming notebook which was suspended in dual-head makes it freeze
[gm45] resuming notebook which was suspended in dual-head makes it freeze
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-intel (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-12 17:48 EDT by Matěj Cepl
Modified: 2011-08-17 16:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-17 16:15:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (805.92 KB, text/plain)
2010-05-12 17:48 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Matěj Cepl 2010-05-12 17:48:42 EDT
Created attachment 413579 [details]
/var/log/messages

Description of problem:
When I suspend notebook in dual-head setup while monitor is connected to the computer and active and then resume at home without a monitor, I get monitor in resolution like with dual head (so there is just part of the desktop visible on the display), but computer is completely stone frozen ... no network, no switching to console, no anything.

Version-Release number of selected component (if applicable):
kernel-2.6.32-24.el6.x86_64
xorg-x11-drv-intel-2.10.902-1.el6.x86_64

How reproducible:
happened once out of one attempt; will test again when I get eventually back to the office to the monitor

Steps to Reproduce:
1.see above
2.
3.
  
Actual results:
frozen computer

Expected results:
Xorg should recognize not having monitor and switch back to single-head on resume

Additional info:
Comment 2 RHEL Product and Program Management 2010-05-12 19:18:43 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Adam Jackson 2010-05-18 15:47:45 EDT
What hardware is this with?
Comment 4 Adam Jackson 2010-06-24 13:23:14 EDT
Ping?  Matej, what hardware is this with?
Comment 5 Matěj Cepl 2010-06-24 17:57:11 EDT
Computer was T400 with

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

monitor I don't know, would have to invesitgate in the office which will happen on Tuesday the earliest.
Comment 6 Adam Jackson 2010-06-28 15:44:39 EDT
Does the machine panic (keyboard LEDs blinking), or just freeze?  If it just freezes then this could easily be a BIOS bug.
Comment 7 RHEL Product and Program Management 2010-07-15 10:59:03 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 9 RHEL Product and Program Management 2011-01-07 11:00:49 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 10 RHEL Product and Program Management 2011-02-01 01:06:53 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 11 RHEL Product and Program Management 2011-02-01 13:20:20 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 12 RHEL Product and Program Management 2011-04-03 22:34:47 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 13 Adam Jackson 2011-08-17 16:15:25 EDT
In my suspend testing of RHEL 6.2 on GM45, I've been unable to reproduce this issue.

Closing.  Please reopen if this issue still occurs on a current 6.2 image.

Note You need to log in before you can comment on or make changes to this bug.