Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 591734 - evolution forwards messages as an incompatible eml file
evolution forwards messages as an incompatible eml file
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution-mapi (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-12 18:37 EDT by Chad Feller
Modified: 2010-05-13 04:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-13 04:15:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 618514 None None None Never

  None (edit)
Description Chad Feller 2010-05-12 18:37:33 EDT
Description of problem:
when forwarding a message from evolution, using the mapi connector, the message is forwarded as an eml file that is unrecognizable by most mail clients.

When forwarding a simple plain-text message to myself at Gmail, Yahoo!, and another IMAP account, I only received a blank email with an attachment: ATT60520..eml.  Gmail, Yahoo!, and SeaMonkey 2 (same code base as TB3), didn't know what to do with this message.

I also cc'd the same message to myself at my exchange account.  I was able to open this with evolution using the mapi connector.  However, Evolution doesn't handle it entirely correct.  The .eml file is handled as plain text regardless if the original message was only plain text or if it also has an attachment itself (say a picture).

Version-Release number of selected component (if applicable):
evolution-mapi-0.30.1-1.fc13.x86_64
evolution-2.30.1-3.fc13.x86_64

How reproducible:
always

Steps to Reproduce:
1. forward any message
2.
3.
  
Actual results:
message cannot be opened by recipient.

Expected results:
message can be opened

Additional info:
this seems to be mapi specific as this problem wasn't a problem when accessing this account via IMAP.

the workaround is to forward messages as "inline".
Comment 1 Milan Crha 2010-05-13 04:15:13 EDT
Thanks for a bug report. For receiving message as attachments is filled an upstream bug [1], which fix was done for 0.31.2 only, because of large changes there.

For sending email attachments I did not find a bug report, thus I filled a new one [2]. Please see [2] for any further updates.

The last thing, incorrectly showing attachments in evolution, there is an upstream bug report [3] about it.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=599311
[2] https://bugzilla.gnome.org/show_bug.cgi?id=618514
[3] https://bugzilla.gnome.org/show_bug.cgi?id=604498

Note You need to log in before you can comment on or make changes to this bug.