Bug 591764 - [Intel 5.6 Bug] ixgbe VFs cannot be assigned to PV guest
[Intel 5.6 Bug] ixgbe VFs cannot be assigned to PV guest
Status: CLOSED DUPLICATE of bug 582886
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.6
All Linux
low Severity medium
: rc
: 5.6
Assigned To: Don Dugger
Red Hat Kernel QE team
:
Depends On:
Blocks: 516248 576676
  Show dependency treegraph
 
Reported: 2010-05-12 23:44 EDT by Don Dugger
Modified: 2014-07-24 23:23 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-16 04:01:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Dugger 2010-05-12 23:44:59 EDT
Upstream Xen had a problem that Niantic VFs couldn't be assigned because the
PCIe capability structure was all 0's, a patch to fix that was pushed upstream.
 This is a fix to passthru.c in qemu which caused different behavior in
upstream Xen but this might be related and we need to make sure we've
backported this fix to RHEL, this fix went into Xen 3.4.2.

According to Dexuan Cui the change sets are as follows:

2) to assign the Niantic VF to PV DomU(rather than Dom0), Dom0 needs the
patches: upstream linux-2.6.18-xen.hg tree's
changeset 998: 693c40564c8d 
changeset 999: 4b0c1a686393
changeset 1003: f66d155ce457
Comment 1 Paolo Bonzini 2010-08-16 04:01:15 EDT

*** This bug has been marked as a duplicate of bug 582886 ***

Note You need to log in before you can comment on or make changes to this bug.