Bug 591773 - SELinux is preventing /usr/libexec/kde4/kdm_greet "write" access on /bin.
SELinux is preventing /usr/libexec/kde4/kdm_greet "write" access on /bin.
Status: CLOSED DUPLICATE of bug 590883
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
13
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:d3045667d80...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-13 00:51 EDT by Magnus Tuominen
Modified: 2010-05-13 11:51 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-13 08:42:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Magnus Tuominen 2010-05-13 00:51:49 EDT
Summary:

SELinux is preventing /usr/libexec/kde4/kdm_greet "write" access on /bin.

Detailed Description:

SELinux denied access requested by kdm_greet. It is not expected that this
access is required by kdm_greet and this access may signal an intrusion attempt.
It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:bin_t:s0
Target Objects                /bin [ dir ]
Source                        kdm_greet
Source Path                   /usr/libexec/kde4/kdm_greet
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           kdm-4.4.3-1.fc13.1
Target RPM Packages           filesystem-2.4.31-1.fc13
Policy RPM                    selinux-policy-3.7.19-15.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.3-85.fc13.x86_64 #1 SMP Thu
                              May 6 18:09:49 UTC 2010 x86_64 x86_64
Alert Count                   16
First Seen                    Thu 13 May 2010 07:26:45 AM EEST
Last Seen                     Thu 13 May 2010 07:48:20 AM EEST
Local ID                      55d4a83e-4776-429b-8637-94e3fe23027a
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1273726100.653:17): avc:  denied  { write } for  pid=2036 comm="kdm_greet" name="bin" dev=dm-0 ino=289 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:bin_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1273726100.653:17): arch=c000003e syscall=21 success=no exit=-13 a0=195c798 a1=2 a2=7fff35266ed0 a3=8 items=0 ppid=2024 pid=2036 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="kdm_greet" exe="/usr/libexec/kde4/kdm_greet" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,kdm_greet,xdm_t,bin_t,dir,write
audit2allow suggests:

#============= xdm_t ==============
#!!!! The source type 'xdm_t' can write to a 'dir' of the following types:
# pcscd_var_run_t, xdm_home_t, pam_var_console_t, xkb_var_lib_t, xdm_rw_etc_t, var_lock_t, root_t, tmp_t, var_t, user_fonts_t, user_tmpfs_t, user_home_dir_t, xdm_spool_t, fonts_cache_t, locale_t, var_auth_t, tmpfs_t, user_tmp_t, var_spool_t, auth_cache_t, xdm_tmpfs_t, var_lib_t, var_run_t, xdm_tmp_t, xserver_log_t, var_log_t, xdm_log_t, pam_var_run_t, xdm_var_lib_t, xdm_var_run_t, gconf_home_t

allow xdm_t bin_t:dir write;
Comment 1 Daniel Walsh 2010-05-13 08:42:26 EDT

*** This bug has been marked as a duplicate of bug 590883 ***

Note You need to log in before you can comment on or make changes to this bug.