Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 591774 - screen remains dim when coming back from idle [NEEDINFO]
screen remains dim when coming back from idle
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-power-manager (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Richard Hughes
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-13 00:59 EDT by Devin Reade
Modified: 2017-12-06 07:26 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 07:26:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rhughes: needinfo? (gdr)


Attachments (Terms of Use)
dmesg output (63.16 KB, text/plain)
2010-05-13 00:59 EDT, Devin Reade
no flags Details

  None (edit)
Description Devin Reade 2010-05-13 00:59:14 EDT
Created attachment 413630 [details]
dmesg output

Description of problem:

RHEL6.0 beta install on a Lenovo Thinkpad T500 (discrete graphics mode).

If the text console is showing (via ctrl-alt-F2) and the machine is left idle for a while, the screen blanker kicks in.  However, when a key is kit thus causing the login prompt to become visible again, the display is set to its dimmest setting.  Using the thinkpad keys to increase the display brightness has no effect while in text mode. Using alt-F1 to go back to graphics mode, the graphics screen is at its dimmest setting as well.  Once in graphics mode, the thinkpad keys can be used to increase the brightness again.

In gnome-power-manager for AC power (where this occurs), the box "Dim display when idle" is NOT checked and "set display brightness to" is 100%.  (For battery power, "dim display when idle" is checked.)

If the system is in graphics mode when it goes idle and the display is blanked out, then it is at the proper brightness when a key is pressed.

Let me know what other diags are desired. (dmesg attached)

Version-Release number of selected component (if applicable):
gnome-power-manager-2.28.2-2.el6.x86_64

How reproducible:


Steps to Reproduce:
1. Ctrl-alt-F2 to get to text login prompt
2. Let the system go idle.  The screen will blank
3. Touch a key.  The screen will unblank but will be very dim
  
Actual results: on return from idle, the display is set to its dimmest setting


Expected results: on return from idle, the display should be at the original brightness
Comment 2 RHEL Product and Program Management 2010-05-13 02:37:37 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Taunus 2010-06-04 07:41:39 EDT
Also when you try to adjust brightness back to normal in login screen it does not work. It works after logging in. T400 with discrete graphics, ati mobility radeon hd 3470.
Comment 4 RHEL Product and Program Management 2010-07-15 10:23:29 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 5 Taunus 2010-08-24 08:41:44 EDT
Testing
Comment 6 Taunus 2010-08-26 08:32:36 EDT
Yeah it is still an issue with beta2refresh
Comment 7 RHEL Product and Program Management 2011-04-03 21:51:04 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 8 Richard Hughes 2014-05-20 04:45:40 EDT
The brightness is not supposed to be changed when sitting on a different VT. Can you do something like this and post the logs please:

(in vt7, i.e. X)

killall gnome-power-manager
gnome-power-manager --verbose

Then switch to vt1, wait for the bug, then post the complete logs. Thanks.
Comment 9 gingerling 2016-06-16 06:37:46 EDT
think I have this, my brightness keeps going down to zero and staying there
Comment 10 Jan Kurik 2017-12-06 07:26:02 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.