Bug 591779 - Does apache-commons-compress-javadoc need to obsolete jakarta-commons-compress-javadoc?
Summary: Does apache-commons-compress-javadoc need to obsolete jakarta-commons-compres...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: apache-commons-compress
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Sandro Mathys
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-13 05:56 UTC by Bruno Wolff III
Modified: 2010-05-15 20:46 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-05-14 20:43:53 UTC


Attachments (Terms of Use)

Description Bruno Wolff III 2010-05-13 05:56:32 UTC
Description of problem:
When doing a yum update apache-commons-compress isn't getting installed because of a dependency issue and apache-commons-compress-doc isn't being grabbed as a replacement for jakarta-commons-compress-javadoc.
--> Running transaction check
---> Package apache-commons-compress.noarch 0:1.0-4.fc13 set to be updated
--> Processing Dependency: jakarta-commons-compress = 1.0-1.fc13 for package: jakarta-commons-compress-javadoc-1.0-1.fc13.noarch
--> Finished Dependency Resolution

Packages skipped because of dependency problems:
    apache-commons-compress-1.0-4.fc13.noarch from updates

This sure looks like there is a missing obsoletes for jakarta-commons-compress-javadoc in apache-commons-compress-javadoc.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Sandro Mathys 2010-05-13 22:11:03 UTC
Bruno, thanks for the report. You are totally right I messed up the javadoc pkg in the renaming process. Will try to fix that ASAP. Sorry for the inconvenience.

Comment 2 Fedora Update System 2010-05-13 22:28:38 UTC
apache-commons-compress-1.0-5.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/apache-commons-compress-1.0-5.fc12

Comment 3 Fedora Update System 2010-05-13 22:29:23 UTC
apache-commons-compress-1.0-5.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/apache-commons-compress-1.0-5.fc13

Comment 4 Bruno Wolff III 2010-05-14 12:26:58 UTC
The update fixes the problem and the update goes smoothly now. Thanks.

Comment 5 Sandro Mathys 2010-05-14 20:43:53 UTC
Thanks for verifying this and the feedback.

Comment 6 Fedora Update System 2010-05-15 20:20:42 UTC
apache-commons-compress-1.0-5.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2010-05-15 20:46:08 UTC
apache-commons-compress-1.0-5.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.