Bug 591818 - unable to "mount" local directory over custom location
unable to "mount" local directory over custom location
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nautilus (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Tomáš Bžatek
desktop-bugs@redhat.com
:
: 619703 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-13 05:03 EDT by Lubos Kocman
Modified: 2015-03-03 17:48 EST (History)
3 users (show)

See Also:
Fixed In Version: nautilus-2.28.4-11.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:11:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of alert (87.75 KB, image/jpeg)
2010-05-13 05:03 EDT, Lubos Kocman
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 601848 None None None Never

  None (edit)
Description Lubos Kocman 2010-05-13 05:03:02 EDT
Description of problem:

I'm unable to "mount" more likely add local directory e.g. /var/tmp over Places-> Connect to server -> Custom Location -> uri /var/tmp

This was working on rhel 5.5. Directory appeared on the desktop with description /var/tmp over null.

Version-Release number of selected component (if applicable):

RHEL 6.0 snapshot 2

nautilus-2.28.4-10.el6.i686
totem-nautilus-2.28.5-6.el6.i686
nautilus-open-terminal-0.17-3.el6.i686
nautilus-extensions-2.28.4-10.el6.i686
brasero-nautilus-2.28.3-5.el6.i686
nautilus-sendto-2.28.2-2.el6.i686
gnome-vfs2-2.24.2-5.el6.i686
gnome-vfs2-smb-2.24.2-5.el6.i686


How reproducible:


Steps to Reproduce:
1. click on gnome-panel -> Places
2. click on Connect to server
3. service type: Custom location
4. Location (URI): /var/tmp
  
Actual results:

You must enter a name for the server
Please enter a name and try again.

Expected results:

Directory should be visible from desktop, with information that it's mounted over null.

Additional info:

drwxrwxrwt. 3 root root 4096 May 13 10:25 /var/tmp
Comment 1 Lubos Kocman 2010-05-13 05:03:32 EDT
Created attachment 413687 [details]
screenshot of alert
Comment 3 RHEL Product and Program Management 2010-05-13 06:24:06 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Tomáš Bžatek 2010-05-20 10:44:52 EDT
This is upstream bug https://bugzilla.gnome.org/show_bug.cgi?id=601848, posted a patch there. Waiting few days to get some feedback from upstream.
Comment 5 Tomas Pelka 2010-06-21 04:23:27 EDT
No more mentioned error. Lubos please could you confirm?

nautilus.x86_64 0:2.28.4-11.el6

Thanks
Comment 6 Lubos Kocman 2010-06-21 04:45:29 EDT
Hi,

the error message was changed to:

"Cannot display location "/home/". volume doesn't implement mount"

1) Which seems reasonable to me, if RedHat is not going to support this feature any more. In this case it's ok.

2) But if it should work, then I have to say that it's not working:

$ rpm -qa gvfs* nautilus
gvfs-fuse-1.4.3-9.el6.x86_64
gvfs-obexftp-1.4.3-9.el6.x86_64
gvfs-smb-1.4.3-9.el6.x86_64
gvfs-gphoto2-1.4.3-9.el6.x86_64
gvfs-1.4.3-9.el6.x86_64
gvfs-archive-1.4.3-9.el6.x86_64
nautilus-2.28.4-11.el6.x86_64
gvfs-afc-1.4.3-9.el6.x86_64
Comment 7 Lubos Kocman 2010-06-21 07:19:12 EDT
As this seems to be expected behaviour I believe that we can move this as verified.
Comment 8 Tomáš Bžatek 2010-06-24 11:02:27 EDT
OK, let's shed some light on how this works. Since transition from gnome-vfs2 to GIO the behaviour has changed a little bit. First, you shouldn't use plain "/home/" string as a URI, this should be file:///home/. This however still works in the Run dialog (Alt+F2 by default).

Second, there won't be any icon on the desktop as the local fs is always mounted, no matter what directory (we always fall back to root, except for some protocols). The philosophy has changed, you should use bookmark for this now, if you want to save the connection somehow.

So yes, this is expected behaviour. My change was to make the Custom URI entry work again.
Comment 9 Tomáš Bžatek 2010-07-30 04:54:01 EDT
*** Bug 619703 has been marked as a duplicate of this bug. ***
Comment 10 releng-rhel@redhat.com 2010-11-10 16:11:44 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.