Bug 59183 - RFE:simplify package selection
RFE:simplify package selection
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-01 13:29 EST by daniel
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description daniel 2002-02-01 13:29:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; T312461)

Description of problem:
right now, the package installation is far too complex for an enduser used to 
the windows environment.  selecting your software should be just that, picking 
the programs _by name_ and installing them.  someone who doesn't understand 
what library files are shouldn't have to wonder if they should be installing 
them as well.  for example, the end user should be able to select kde a kde gui 
and ask for all relevent packages, but they should also be able to say "include 
konqueror and lynx, and no other ftp programs".  instead of what we have now, 
an ambiguous list of "internet applications" including cryptic names for 
programs i *think* i don't need.  if the installer is to be an easy thing, then 
i should be able to select the programs by name, as they are sorted by type:

web apps
 -browsing
  .mozilla
  .netscrape
  .konqueror
  .galleon
  .lynx
  .links
 -email
  .evolution
  .kmail
  .pine
  .elm
 -ftp
  .ncftp
  .gftp
  .krusader
productivity
 -office
  .star office
  .koffice
 -accessories
  .calc
  .korganiser

etc. etc.

nothing else needs to appear on the list, and all required packages should be 
installed as needed.

this would of course only be an option, and not the *only* form of 
installation.  one should be able to select individual packages before/after 
the simple install, it's just that the simple install would give you a little 
more configurability than what we have now:
  gui
   kde
   gnome
  networking
   yes
   no
  games
   yes
   no
...
it's _too_ simple.
and in order to get specific programs, i have to know the names of each one, 
AND know their associated lib, devel files...  no one should be expected to 
understand if they need libxxxx.so.n just to check their email and write a few 
letters.

i hope i'm making sense


Additional info:

i've made postings to enigma-list@redhat.com about this and was encouraged to 
put all of my thoughts here...  checking the list archives might better 
describe what i'm trying to say.  the subject header was "next release of 
redhat installer"  (lowercased) and took place beween jan30 - jan31 2002.
Comment 1 Michael Fulbright 2002-03-26 12:32:49 EST
Deferring to future release.
Comment 2 Red Hat Bugzilla 2006-02-21 13:48:24 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.