Bug 59185 - [patch] for nash to support mount "-o options"
[patch] for nash to support mount "-o options"
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
7.2
All Linux
low Severity medium
: ---
: ---
Assigned To: Matt Wilson
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-01 14:21 EST by paluch
Modified: 2007-03-26 23:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-01 14:22:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nash - enhanced version of mount, that allows passing fs options (1.25 KB, patch)
2002-02-01 14:22 EST, paluch
no flags Details | Diff

  None (edit)
Description paluch 2002-02-01 14:21:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-21 i686)

Description of problem:
Hi!
  I'm sending a little patch for nash, that allows passing mount options to
mount command.
I found it useful to mount ext3 root in data=writeback in initrd image
(kernel forbids later change when remounting ro -> rw).

Best regards
  Henryk Paluch
Comment 1 paluch 2002-02-01 14:22:19 EST
Created attachment 44276 [details]
nash - enhanced version of mount, that allows passing fs options
Comment 2 Erik Troan 2002-05-20 22:00:20 EDT
added (via different patch) to mkinitrd 3.3.11 -- thanks
Comment 3 Pádraig Brady 2003-08-26 11:55:43 EDT
This is related I think?

The mount command in nash (3.5.8) doesn't
like the noauto option (which was in my fstab),
causing the mount to fail.
I guess this is because the standard mount
command strips this before sending to ext2?
Maybe mkinitrd is the correct place to strip
this? 
Comment 4 Matt Wilson 2003-08-26 12:10:25 EDT
nash should only include mount lines for your root partition.  this means that
you have a root partition (/) entry in /etc/fstab that has a noauto option? 
Could you attach your fstab?
Comment 5 Pádraig Brady 2003-08-26 12:27:41 EDT
true,

I removed the noauto to get around the problem,
but from a logical point of view it should
handle the same things as ordinary mount does IMHO.

(I had marked all filesystems as noauto that
won't/shouldn't be mounted by a `mount -a`
in my startup scripts).

Note You need to log in before you can comment on or make changes to this bug.