Bug 591861 - vgscan (with cluster locking) doesn't remove filtered devices from .cache after filter change
Summary: vgscan (with cluster locking) doesn't remove filtered devices from .cache aft...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2-cluster   
(Show other bugs)
Version: 5.5
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Milan Broz
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords: Regression, ZStream
Depends On:
Blocks: 592220
TreeView+ depends on / blocked
 
Reported: 2010-05-13 11:35 UTC by Milan Broz
Modified: 2013-03-01 04:09 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 22:44:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0053 normal SHIPPED_LIVE lvm2-cluster bug fix and enhancement update 2011-01-12 17:22:43 UTC

Description Milan Broz 2010-05-13 11:35:31 UTC
Description of problem:
vgscan should clean /etc/lvm/cache/.cache and refresh its contents according
to dev filter in lvm.conf.

This doesn't work with clustered lvm locking (only new devices are added).

User must manually remove .cache file to properly refresh filter.

Version-Release number of selected component (if applicable):
lvm2-cluster-2.02.56-7.el5

This is regression caused by commit c1b2049df907c0904faa07d01a23138b75dc3cfd

Version 2.02.56 - 
====================================
Move persistent filter dump to more appropriate place.

Comment 2 Milan Broz 2010-05-13 13:00:15 UTC
See also report here
https://www.redhat.com/archives/linux-lvm/2010-May/msg00012.html

Comment 3 Milan Broz 2010-05-13 15:00:34 UTC
Fixed in upstream cvs -> POST for now.

Comment 5 Milan Broz 2010-05-14 09:42:19 UTC
Fix in lvm2/lvm2-cluster-2.02.56-11.el5.

Comment 8 Corey Marthaler 2010-10-12 20:00:25 UTC
Fix verified in lvm2-cluster-2.02.73-2.el5 (device was no longer listed in .cache file once filtered out and vgscan'ed).

Comment 10 errata-xmlrpc 2011-01-13 22:44:07 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0053.html


Note You need to log in before you can comment on or make changes to this bug.