Bug 591877 - [abrt] crash in quake3-1.36-6.fc12: Process /usr/bin/quake3 was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in quake3-1.36-6.fc12: Process /usr/bin/quake3 was killed by sig...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: quake3   
(Show other bugs)
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Xavier Lamien
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:4bf16dc87c1e0ca8fa4df5de7c0...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-13 12:04 UTC by Sylvain Petreolle
Modified: 2010-07-12 08:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-12 08:16:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (12.45 KB, text/plain)
2010-05-13 12:04 UTC, Sylvain Petreolle
no flags Details

Description Sylvain Petreolle 2010-05-13 12:04:15 UTC
abrt 1.0.9 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: quake3
comment: Run quake3 with aoss since alsa is in use.
component: quake3
executable: /usr/bin/quake3
global_uuid: 4bf16dc87c1e0ca8fa4df5de7c0c81f6d9acf087
kernel: 2.6.32.11-99.fc12.i686.PAE
package: quake3-1.36-6.fc12
rating: 3
reason: Process /usr/bin/quake3 was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. Stop pulseaudio (start-pulseaudio-x11 -k)
2. Run an alsa app (qemu in my case)
3. start quake3 using aoss

Comment 1 Sylvain Petreolle 2010-05-13 12:04:19 UTC
Created attachment 413734 [details]
File: backtrace

Comment 2 Hans de Goede 2010-07-12 08:16:58 UTC
quake3 in Fedora is ioquake3 which uses SDL for sound output (and thus should  work fine with alsa and/or through pulse audio).

The crash you've reported is happening is inside libalsa, and likely caused by the unnecessary trickery you are using to try and get sound.


Note You need to log in before you can comment on or make changes to this bug.