Bug 59188 - rh-pgdump.sh script doesn't work, etc.
Summary: rh-pgdump.sh script doesn't work, etc.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: postgresql (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-01 19:59 UTC by Elliot Lee
Modified: 2007-04-18 16:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-01 19:59:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Elliot Lee 2002-02-01 19:59:39 UTC
The rh-pgdump.sh script (given in the documentation as part of the standard
upgrade procedure) tries to call /usr/lib/pgsql/backup/pg_dumpall_new

The script is installed, however, as /usr/share/pgsql/backup/pg_dumpall_new

Also, the initscript's message about finding an old version of the database
includes an embedded literal "\n" string, which probably should be a newline.

In general, the postgres 7.1 -> 7.2 upgrade process needs simplification - I
didn't manage a successful upgrade even after adding a pg_dumpall_new symlink.

Comment 1 Trond Eivind Glomsrxd 2002-02-08 21:10:32 UTC
Th rh-pgdump script has been deprecated in 7.2-2 - it was useful for 6.5 -> 7


Note You need to log in before you can comment on or make changes to this bug.