Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 591885 - Disable CONFIG_DEBUG_RODATA on kernel-debug package
Summary: Disable CONFIG_DEBUG_RODATA on kernel-debug package
Keywords:
Status: CLOSED DUPLICATE of bug 557364
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: 6.0
Assignee: Aristeu Rozanski
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-13 12:40 UTC by Matthew Whitehead
Modified: 2010-07-26 22:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-26 22:25:36 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Matthew Whitehead 2010-05-13 12:40:09 UTC
Description of problem: Disable CONFIG_DEBUG_RODATA on kernel-debug package


Version-Release number of selected component (if applicable): RHEL6.0


Disable the CONFIG_DEBUG_RODATA config option for the kernel-debug package. It is normally on, but should be disabled in the kernel-debug package so you can attach a remote debugger to it.

When this is enabled (normal situation), it causes breakpoints to fail. This makes a kernel debugger essentially useless.

Since so many configuration options are changed in the kernel-debug package, this is the right package to toggle the CONFIG_DEBUG_RODATA option.

Comment 3 RHEL Program Management 2010-05-13 14:07:01 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.


Note You need to log in before you can comment on or make changes to this bug.