Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 591889 - nss_pcache dies by a sighup
nss_pcache dies by a sighup
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mod_nss (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Rob Crittenden
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-13 08:44 EDT by Joshua Roys
Modified: 2010-06-04 14:51 EDT (History)
2 users (show)

See Also:
Fixed In Version: mod_nss-1.0.8-6.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-04 14:46:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
signal(SIGHUP, SIG_IGN) (465 bytes, patch)
2010-05-13 08:44 EDT, Joshua Roys
no flags Details | Diff

  None (edit)
Description Joshua Roys 2010-05-13 08:44:15 EDT
Created attachment 413751 [details]
signal(SIGHUP, SIG_IGN)

Description of problem:
nss_pcache dies by a sighup, causing mod_nss to behave badly

Version-Release number of selected component (if applicable):
1.0.8-4

How reproducible:
configure mod_nss as the ssl provider for httpd

Steps to Reproduce:
1. configure mod_nss/httpd
2. start it
3. watch httpd children scream as they can't open the password-protected cert db because nss_pcache died
  
Actual results:
non-working ssl

Expected results:
working httpd w/ssl via mod_nss
Comment 1 Rob Crittenden 2010-05-13 10:59:16 EDT
What would send nss_pcache a sighup?
Comment 2 Joshua Roys 2010-05-13 11:26:43 EDT
We would notice it whenever we started httpd via the initscripts... we use a strict/mls selinux policy, so we use run_init:
run_init service httpd start

And then nss_pcache would die.  A strace would reveal it getting sent a sighup when the parent (IIRC, I can double check later) process started to close the std{in,out,err} file descriptors.  It almost seemed to be a race condition, because sometime it wouldn't die - usually under a debugger or something else that would slow various pieces down.

man 7 signal:
       SIGHUP        1       Term    Hangup detected on controlling terminal
                                     or death of controlling process
Comment 3 Rob Crittenden 2010-05-14 11:49:08 EDT
Very easy to reproduce, I don't see a problem ignoring this signal.

Committed upstream.

Checking in nss_pcache.c;
/cvs/dirsec/mod_nss/nss_pcache.c,v  <--  nss_pcache.c
new revision: 1.11; previous revision: 1.10
done
Comment 4 Fedora Update System 2010-05-17 16:23:27 EDT
mod_nss-1.0.8-6.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/mod_nss-1.0.8-6.fc12
Comment 5 Fedora Update System 2010-05-17 16:23:36 EDT
mod_nss-1.0.8-6.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/mod_nss-1.0.8-6.fc13
Comment 6 Fedora Update System 2010-05-18 17:56:03 EDT
mod_nss-1.0.8-6.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mod_nss'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/mod_nss-1.0.8-6.fc13
Comment 7 Fedora Update System 2010-05-18 17:56:48 EDT
mod_nss-1.0.8-6.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mod_nss'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/mod_nss-1.0.8-6.fc12
Comment 8 Fedora Update System 2010-06-04 14:45:59 EDT
mod_nss-1.0.8-6.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2010-06-04 14:51:46 EDT
mod_nss-1.0.8-6.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.