Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 591899 - Cloning an already cloned channel doesn't clone all the errata
Cloning an already cloned channel doesn't clone all the errata
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
high Severity high
: ---
: ---
Assigned To: Justin Sherrill
Martin Minar
: Reopened
Depends On:
Blocks: sat540-blockers
  Show dependency treegraph
 
Reported: 2010-05-13 08:59 EDT by Vishal Gaikwad
Modified: 2016-07-03 20:55 EDT (History)
9 users (show)

See Also:
Fixed In Version: spacewalk-web-1.2.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-28 10:50:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vishal Gaikwad 2010-05-13 08:59:50 EDT
Description of problem:
Cloning a cloned base channel w/ errata does not seem to bring errata to 2nd generation clone.

Clone channel w/ errata reports no errata. Clone this cloned channel w/ errata shows lots of  errata (1000+) are available.

Version-Release number of selected component (if applicable):
RHNS 530

How reproducible:
Always

Steps to Reproduce:
* Clone Red Hat Enterprise Linux channel to "clone_channel_a" w/ all errata
* Go to "clone_channel_a" -> Errata -> Clone: 0 available
* Clone  "clone_channel_a" -> "clone_channel_b" w/ all errata
* Go to "clone_channel_b" -> Errata -> Clone: ~1000 available
  
Actual results:
Clone page shows cloneable errata

Expected results:
Should not show any errata as we have cloned the channel with all errata.

Additional info:
Issue is reproduced locally.
Comment 2 Miroslav Suchý 2010-06-25 11:06:25 EDT
Duplicate. This has been already fixed by errata

*** This bug has been marked as a duplicate of bug 528170 ***
Comment 4 Vishal Gaikwad 2010-08-18 08:57:37 EDT
Hello Mirek,

What is the plan for fixing this? 

Customer changed the way they work to avoid "cascading cloning" but they won't be able to avoid it on the long term and need to know when we will fix this.

regards,
Comment 5 Justin Sherrill 2010-09-10 14:33:48 EDT
fixed:  1636e1a9cf90da8b946a25782313f2cd48c8b4e6

Looked like that page was never really made to work with clones of clones properly.
Comment 8 Justin Sherrill 2010-09-21 16:17:00 EDT
Martin,

I'm not able to reproduce this on https://ibm-zeus-02.rhts.eng.bos.redhat.com/

In fact your reproducer doesn't seem to have reproduced it?  When i go to https://ibm-zeus-02.rhts.eng.bos.redhat.com/network/software/channels/manage/errata/clone.pxt?cid=161  I dont' see any errata listed which seems correct.

I tried reproducing with justin1 and clone-justin1  and that seemed fine too.

-Justin
Comment 9 Justin Sherrill 2010-09-21 16:56:10 EDT
Throwing to on_qa as cliff suggsted.
Comment 10 Martin Minar 2010-09-22 02:41:17 EDT
Yes, sorry, I was looking into wrong tab (Errata > Clone Errata).
Comment 12 Garik Khachikyan 2010-10-18 07:17:53 EDT
# VERIFIED against errata.stage (signed packages - satellite-5.4.0-20101015-rhel-5)

Scenario:
1. make a custom channel - clone RHEL5 base channel (1403 - RHEL5 i386 [the same as the original Red Hat base channel has])
2. make a custom channel - cloning the cloned channel step above (the same amount of erratas available - 1403).

So the issue is re-checked / confirmed to be fixed properly.
Comment 13 Clifford Perry 2010-10-28 10:45:34 EDT
The 5.4.0 RHN Satellite and RHN Proxy release has occurred. This issue has been resolved with this release. 


RHEA-2010:0801 - RHN Satellite Server 5.4.0 Upgrade
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10332

RHEA-2010:0803 - RHN Tools enhancement update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10333

RHEA-2010:0802 - RHN Proxy Server 5.4.0 bug fix update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10334

RHEA-2010:0800 - RHN Satellite Server 5.4.0
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10335

Docs are available:

http://docs.redhat.com/docs/en-US/Red_Hat_Network_Satellite/index.html 

Regards,
Clifford

Note You need to log in before you can comment on or make changes to this bug.