Bug 591912 - Some keyboard commands ignored
Some keyboard commands ignored
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: evolution (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Matthew Barnes
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-13 09:32 EDT by Marc Milgram
Modified: 2013-06-20 10:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-20 10:55:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc Milgram 2010-05-13 09:32:10 EDT
Description of problem:
Usually while reading mail in evolution, I am able to pres the space bar to read more of the message, or if at the end of the message read the next message.  Sometimes evolution doesn't respond to space.

Version-Release number of selected component (if applicable):
evolution-2.28.3-3.el6.x86_64

How reproducible:
Randomly

Steps to Reproduce:
1. Start evolution
2. Read email
  
Actual results:
Occasionally the folder will be selected with a blue bar, the mail message with a gray bar, and space bar will be ignored.

Expected results:
Space bar views more of the message, or if at the end of message, goes to the next unread message.

Additional info:
I use imap4s, gssapi, 25 email folders, and thousands of unread email messages coming into numerous folders.
Comment 2 Marc Milgram 2010-05-13 09:36:28 EDT
During normal operation, the email message in the message list is highlighted blue.  In the errant case, it is gray.
Comment 3 Milan Crha 2010-05-13 09:59:58 EDT
Thanks for a bug report. What you are describing is called "magic space bar". There is an option in Preferences to turn it on and off. It's sort of known that it doesn't work well for a caret mode, View->Caret mode (F7). Do you have caret mode on or off?
Comment 5 Marc Milgram 2010-05-13 10:26:51 EDT
I have caret mode off.
Comment 6 RHEL Product and Program Management 2010-05-13 11:19:38 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 7 Milan Crha 2010-05-20 14:08:35 EDT
I tried to reproduce it, but it works for me. What I do:
a) mark two messages in some IMAP folder as unread
b) go to IMAP Inbox and select there a message which is long enough to show
   vertical scrollbar in the message preview
c) the focused control is a message list now, as I clicked on the message
   in it with a mouse
d) press SPACE, message scrolls down
e) press it again until it's at the end of the message; next press will move
   to the folder from step a), selecting the first unread message there.
f) repeating from step d) until all messages are read

I thought this is somehow related to the upstream bug [1], but seeing it's for 2.29 and not for 2.28 then it would be something else.

Could you try to find some click & press steps from the evolution start for this, to know how to reproduce this reliably, please?

[1] https://bugzilla.gnome.org/show_bug.cgi?id=612236
Comment 8 RHEL Product and Program Management 2010-07-15 10:31:59 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 10 Suzanne Yeghiayan 2011-03-28 17:08:27 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains 
unresolved, it has been rejected as it is not proposed as an 
exception or blocker.

Red Hat invites you to ask your support representative to 
propose this request, if appropriate and relevant, in the 
next release of Red Hat Enterprise Linux.
Comment 12 RHEL Product and Program Management 2013-06-20 10:55:32 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.