Bug 59192 - letting users override aa font size range with ~/.xftconfig
Summary: letting users override aa font size range with ~/.xftconfig
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-01 21:59 UTC by jacob@ximian.com
Modified: 2007-04-18 16:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-01 21:41:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description jacob@ximian.com 2002-02-01 21:59:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.0.2 (X11; Linux i686; U;) Gecko/20020102

Description of problem:
After the XFree86-4.1.0-15 update, smaller fonts were rendered w/o aa.

while this range is configurable, i cannot override the settings in
/etc/X11/XftConfig by changing things in ~/.xftconfig, because XftConfig
includes .xftconfig at the beginning, then overrides my settings.

Version-Release number of selected component (if applicable):
XFree86-4.1.0-15

How reproducible:
Always

Steps to Reproduce:
1.  edit ~/.xftconfig to contain:

#
# Don't antialias small fonts
#
match
    any size < 12
    any size > 8
    edit antialias=false;

match
    any size >= 12
    edit antialias=true;

2.  run a gnome 2.x application with GDK_USE_XFT=1 set in the environment

	

Actual Results:  Fonts of size 12 are not rendered with AA.

Expected Results:  Fonts of size 12 are rendered with AA.

Additional info:

Comment 1 Mike A. Harris 2002-03-12 13:46:31 UTC
I've made changes to this a while back after chatting in IRC with Keith
Packard about it.  I think our current config is much better now in
XFree86 4.2.0-6.45.  Please let me know if the new packages work better
now for you.

You can catch me on #xfree86 on OPN also to discuss stuff with if you
like.



Note You need to log in before you can comment on or make changes to this bug.