Bug 59194 - [FIX ATTACHED] db2html dosn't like *.xml files
Summary: [FIX ATTACHED] db2html dosn't like *.xml files
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: docbook-utils   
(Show other bugs)
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-01 22:36 UTC by Crutcher Dunnavant
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-05 18:05:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
db2html (745 bytes, text/plain)
2002-02-01 22:37 UTC, Crutcher Dunnavant
no flags Details
db2html (747 bytes, text/plain)
2002-02-01 22:52 UTC, Crutcher Dunnavant
no flags Details
db2html (805 bytes, text/plain)
2002-02-04 19:09 UTC, Crutcher Dunnavant
no flags Details

Description Crutcher Dunnavant 2002-02-01 22:36:46 UTC
Description of Problem:
db2html is a wrapper around jw, and a thin one at that. However, when originally
written, it made assumptions which are no longer true. Specifical, that it would
alwas work on files of the form *.sgml or *.sgm.

The issue is that it uses a line like this:
   output="$(echo $arg | sed 's,\.sgml$,,;s,\.sgm$,,')"
To figgure out the output directory.

This does not work for *.xml files.

Attached is a modified version of db2html, which extends the sed line. It also
adds a command line switch for '-o' which allows explicit setting of the output
directory the way that help says it will.

Comment 1 Crutcher Dunnavant 2002-02-01 22:37:30 UTC
Created attachment 44317 [details]
db2html

Comment 2 Crutcher Dunnavant 2002-02-01 22:51:28 UTC
Oops.

Sorry, use this version (negated a test :(

Comment 3 Crutcher Dunnavant 2002-02-01 22:52:16 UTC
Created attachment 44318 [details]
db2html

Comment 4 Tim Waugh 2002-02-01 23:28:48 UTC
Oops, yes.  I didn't think about XML when I wrote it.  Thanks.


Comment 5 Crutcher Dunnavant 2002-02-04 18:49:22 UTC
the -o switch I put in is all wrong. :(
Trying to fix.

Comment 6 Crutcher Dunnavant 2002-02-04 19:05:25 UTC
This version seems to be much better.
Sorry about the last one. It was friday and I was heading for a date, so I
didn't test it much.

Comment 7 Crutcher Dunnavant 2002-02-04 19:09:32 UTC
Created attachment 44437 [details]
db2html

Comment 8 Tim Waugh 2002-02-05 14:22:21 UTC
Crutcher: learn shell one day. :-)

I see what you're trying to do, and I will fix it for next time.

Comment 9 Tim Waugh 2002-02-06 16:41:22 UTC
Fixed in 0.6.9-21.  I left -o out: if you care, use docbook2html instead.


Note You need to log in before you can comment on or make changes to this bug.