Bug 591953 - resources of type "Postfix Server" are not getting listed in the default /browseResources.xhtml?subtab=server
Summary: resources of type "Postfix Server" are not getting listed in the default /bro...
Status: CLOSED WORKSFORME
Alias: None
Product: RHQ Project
Classification: Other
Component: No Component   
(Show other bugs)
Version: 1.4
Hardware: All
OS: Linux
low
medium vote
Target Milestone: ---
: ---
Assignee: RHQ Project Maintainer
QA Contact: Corey Welton
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-13 14:46 UTC by John Sefler
Modified: 2010-05-18 12:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-18 12:57:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Sefler 2010-05-13 14:46:45 UTC
Description of problem:
On an RHQ Server with a "Postfix Server" inventoried, the postfix server does not get listed in the default listing of the SERVERS resources.  However if you navigate to the ALL resources table, the inventoried Postfix Server is listed.  OR, if you go back to the SERVERS listing and search for the postfix server, it will be found.


Version-Release number of selected component (if applicable):
 RHQ
version: 3.0.0-SNAPSHOT
build number: 96e557c 

How reproducible:
always

Steps to Reproduce:
1. Install a Postfix Server on one of your inventoried platforms and discover it.
2. go to Resources > Servers
3. paginate through the table of servers looking for the type Postfix Server
BANG! You can't find it
4. go to Resources > All Resources
5. paginate through the table of all resources looking for the type Postfix Server
YES! You can find it
6. go back to Resources > Servers
7. paginate through the table of servers looking for the type Postfix Server
BANG! You still cannot find it
8. use the Search tool and search for:   plugin="Postfix"
YES! There is the Postfix Server

Additional info:
If you have already clicked on the "Category" column for sorting, then the Postfix Server is always found and this defect is masked.

Comment 1 John Sefler 2010-05-14 16:23:35 UTC
 RHQ
version: 3.0.0-SNAPSHOT
build number: abc4d3e 

This newer build does NOT appear to exhibit the bug.

Comment 2 John Sefler 2010-05-18 12:57:20 UTC
Closing defect since it is no longer observed in the newer builds... will re-open if we see it again.


Note You need to log in before you can comment on or make changes to this bug.