Bug 591981 - keyboard layout keeps comming back after deletion
keyboard layout keeps comming back after deletion
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: atomorun (Show other bugs)
13
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-13 11:36 EDT by Nikolai Maziashvili
Modified: 2010-05-16 04:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-16 04:03:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikolai Maziashvili 2010-05-13 11:36:30 EDT
Description of problem:
I use US keyboard layout with euro sign on 5. Whenever i edit keyboard layouts and add this particular layout i delete other one (standard US).
But every time i restart system it comes back. 

Version-Release number of selected component (if applicable):


How reproducible:
every time system rebooted only under GNOME DE.

Steps to Reproduce:
1. add keyboard layout of your choice
2. delete standard US layout from the list
3. reboot system and take a look at layout list again
  
Actual results:
2 (two) US layouts (US and US with euro sign on 5).

Expected results:
one US layout of my choice


Additional info:
On daily bases i type in two languages - Georgian and English. i can't tell you how frustrating it is to go through layout delete procedure every time i restart computer.
I switch very often between layouts and it's killing me now to deal with this problem since F12.
Comment 1 Nikolai Maziashvili 2010-05-16 04:03:31 EDT
workaround solves this problem.
In /etc/X11/xorg.conf.d/00-system-setup-keyboard.conf default Xkbdoption set to 'us'. After setting it to 'us euro' i have my euro keyboard layout as default and other layouts. No extra layouts are showing up any more.
As for me this is good enough to close the bug.

Note You need to log in before you can comment on or make changes to this bug.