Bug 591988 - Error messages with 1 error rendering incorrectly in UI
Summary: Error messages with 1 error rendering incorrectly in UI
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI   
(Show other bugs)
Version: unspecified
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Tomáš Kašpárek
QA Contact: Martin Korbel
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: sat560-lowbug
TreeView+ depends on / blocked
 
Reported: 2010-05-13 15:59 UTC by Partha Aji
Modified: 2013-10-01 21:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 21:53:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error message (22.12 KB, image/png)
2013-09-25 11:24 UTC, Martin Korbel
no flags Details

Description Partha Aji 2010-05-13 15:59:37 UTC
So for example go to http://<FQDN>/rhn/activationkeys/Create.do and enter -1 in the Usage Limit and hit create button. Notice the dot before "Usage Limit cannot be less than 0." error. Even though there is only one error it wants embed the error with a <ul><li>. We need to change the error logic to say, if its a single error change it to just render the error without UL and Li, if its more than 1 then use UL LI..

Comment 1 Tomáš Kašpárek 2013-05-16 08:35:21 UTC
fixed in spacewalk.git: 7a8d77b63d95a9d6a37ca064eb2ce8378f753728

I've removed dots at start of errors, as they're rendered on new line each.

Comment 3 Martin Korbel 2013-09-25 11:24:15 UTC
Created attachment 802736 [details]
error message

VERIFIED   on satellite-branding-5.6.0.21-1.el6sat
REPRODUCED on satellite-branding-5.4.0.11-1.el6sat

Comment 4 Clifford Perry 2013-10-01 21:53:00 UTC
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html


Note You need to log in before you can comment on or make changes to this bug.