Bug 591999 - SELinux is preventing /usr/bin/xauth access to a leaked /home/alex/.lyx/lyxpipe.in file descriptor.
SELinux is preventing /usr/bin/xauth access to a leaked /home/alex/.lyx/lyxpi...
Status: CLOSED DUPLICATE of bug 553110
Product: Fedora
Classification: Fedora
Component: lyx (Show other bugs)
13
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:556bd1c67fe...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-13 12:44 EDT by Alex Lancaster
Modified: 2010-07-30 15:41 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-30 15:41:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2010-05-13 12:44:45 EDT
Summary:

SELinux is preventing /usr/bin/xauth access to a leaked
/home/alex/.lyx/lyxpipe.in file descriptor.

Detailed Description:

[xauth has a permissive type (xauth_t). This access was not denied.]

SELinux denied access requested by the xauth command. It looks like this is
either a leaked descriptor or xauth output was redirected to a file it is not
allowed to access. Leaks usually can be ignored since SELinux is just closing
the leak and reporting the error. The application does not use the descriptor,
so it will run properly. If this is a redirection, you will not get output in
the /home/alex/.lyx/lyxpipe.in. You should generate a bugzilla on
selinux-policy, and it will get routed to the appropriate package. You can
safely ignore this avc.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385)

Additional Information:

Source Context                unconfined_u:unconfined_r:xauth_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:user_home_t:s0
Target Objects                /home/alex/.lyx/lyxpipe.in [ fifo_file ]
Source                        xauth
Source Path                   /usr/bin/xauth
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           xorg-x11-xauth-1.0.2-7.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-10.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   leaks
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.3-85.fc13.x86_64
                              #1 SMP Thu May 6 18:09:49 UTC 2010 x86_64 x86_64
Alert Count                   8
First Seen                    Thu 07 Jan 2010 12:32:05 AM EST
Last Seen                     Thu 13 May 2010 12:43:35 PM EDT
Local ID                      0d5f2e02-c1e5-4173-b58c-2b8fdeb80226
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1273769015.313:37352): avc:  denied  { read } for  pid=13063 comm="xauth" path="/home/alex/.lyx/lyxpipe.in" dev=dm-0 ino=1064826 scontext=unconfined_u:unconfined_r:xauth_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=fifo_file

node=(removed) type=AVC msg=audit(1273769015.313:37352): avc:  denied  { read write } for  pid=13063 comm="xauth" path="/home/alex/.lyx/lyxpipe.out" dev=dm-0 ino=1066623 scontext=unconfined_u:unconfined_r:xauth_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=fifo_file

node=(removed) type=SYSCALL msg=audit(1273769015.313:37352): arch=c000003e syscall=59 success=yes exit=0 a0=2732130 a1=272fed0 a2=2730080 a3=20 items=0 ppid=13062 pid=13063 auid=501 uid=501 gid=100 euid=501 suid=501 fsuid=501 egid=100 sgid=100 fsgid=100 tty=pts3 ses=2 comm="xauth" exe="/usr/bin/xauth" subj=unconfined_u:unconfined_r:xauth_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  leaks,xauth,xauth_t,user_home_t,fifo_file,read
audit2allow suggests:

#============= xauth_t ==============
allow xauth_t user_home_t:fifo_file { read write };
Comment 1 Alex Lancaster 2010-05-13 12:46:09 EDT
Happened when I used the "Version Control"->"Check out for Editing" feature on a locked file in a subversion repo.
Comment 2 Alex Lancaster 2010-05-13 12:47:00 EDT
Here are the perms on the pipes, FWIW:

$ ls -lZ .lyx/lyxpipe.*
prw-------. alex users unconfined_u:object_r:user_home_t:s0 .lyx/lyxpipe.in
prw-------. alex users unconfined_u:object_r:user_home_t:s0 .lyx/lyxpipe.out
Comment 3 Daniel Walsh 2010-05-13 14:30:43 EDT
Looks like this tool is leaking open file descriptors to xauth.
Comment 4 Alex Lancaster 2010-07-29 19:09:07 EDT
(In reply to comment #3)
> Looks like this tool is leaking open file descriptors to xauth.    

How should this be fixed?  Report to upstream?
Comment 5 Daniel Walsh 2010-07-30 14:53:36 EDT
I guess the questio nis what is .lyx doing?  Can it close these pipes on exec?
Is this a fedora package?
Comment 6 Alex Lancaster 2010-07-30 15:37:32 EDT
(In reply to comment #5)
> I guess the questio nis what is .lyx doing?  Can it close these pipes on exec?
> Is this a fedora package?    

Yep:

https://admin.fedoraproject.org/community/?package=lyx#package_maintenance

it's a GUI front-end to LaTeX.  I'll re-open and reassign it to the package maintainers and hopefully they can followup with a bug to upstream.
Comment 7 Alex Lancaster 2010-07-30 15:41:51 EDT
Actually this is a dupe of another bug: bug #553110.

*** This bug has been marked as a duplicate of bug 553110 ***

Note You need to log in before you can comment on or make changes to this bug.