Bug 592000 - Firewire does not work with certain Sony cameras
Firewire does not work with certain Sony cameras
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-13 12:47 EDT by Karl S.
Modified: 2010-09-15 08:57 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-15 08:57:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karl S. 2010-05-13 12:47:42 EDT
Attaching a Sony DCR-HC42 Camcorder to the firewire port does not create the device /dev/fw1.  However attaching a similar, newer model, DCR-HC52 works perfectly!

This may in fact be a udev problem, not the kernel - I'm not sure.

Version-Release number of selected component:
kernel-2.6.32.11-99.fc12.i686
udev-145-20.fc12.i686

From dmesg:
firewire_ohci 0000:01:03.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
firewire_ohci: Added fw-ohci device 0000:01:03.0, OHCI version 1.10
firewire_core: created device fw0 [...]
Comment 1 Stefan Richter 2010-05-17 11:01:31 EDT
Please run as root:
# echo -1 > /sys/module/firewire_ohci/parameters/debug
(-1 = minus one)
Then plug in/ switch on the DCR-HC42 and attach the resulting output of dmesg here.  In some cases this may result in heavy activity in the kernel log, hence you may want to watch it with "tail -f /var/log/messages" and stand by to pull the cable before your disk is filled by the messages file. ;-)

Also, please identify your FireWire controller as listed by "lspci -nn".
Comment 2 Karl S. 2010-05-18 21:06:01 EDT
Controller is:
01:03.0 FireWire (IEEE 1394) [0c00]: Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link) [104c:8023]

Kernel debugging output:
May 18 17:58:04 mybox kernel: firewire_ohci: IRQ 00200000 cycle64Seconds
May 18 17:59:08 mybox kernel: firewire_ohci: IRQ 00200000 cycle64Seconds
May 18 18:00:12 mybox kernel: firewire_ohci: IRQ 00200000 cycle64Seconds
May 18 18:01:16 mybox kernel: firewire_ohci: IRQ 00200000 cycle64Seconds

That's all it produces.  Strange.

BTW, this particular camera did work with the same hardware and the old raw1394 drivers in Fedora 10.
Comment 3 Karl S. 2010-05-18 21:09:24 EDT
One more thing...

The newer camera works, but now I see that it only works ONCE.  I can do only one capture with Kino, and after that /dev/fw1 disappears.  I am unable to bring that device back without rebooting.

That may be a different bug though...
Comment 4 Stefan Richter 2010-05-20 19:22:21 EDT
Re comment 2:
Very much looks like defective hardware.  If you can spare a minute for this, please also try "modprobe -r firewire-ohci; modprobe firewire-ohci debug=-1" and plug the camera in.  This will enable one more interrupt logging bit that the echo command from comment 1 does not provide.

What do you mean by "the old raw1394 drivers in Fedora 10"?  Fedora stopped shipping ohci1394/ieee1394/raw1394 after Fedora 6.  Did you install a 3rd party package with these modules?  If the latter, could you try that again?
Comment 5 Karl S. 2010-05-23 18:51:00 EDT
OK I tried the new command you provided and got the same results.  Using the new camera, the log fills up as you mentioned earlier :)

Regarding my previous Fedora 10 installation, it had persistent /dev/raw1394 and /dev/video1394 device files, and I had to change my Kino config after this upgrade to use the new /dev/fw1.  I honestly can't remember how the previous system was configured but it is possible I used a 3rd party package.

I suppose this *could* be a problem with the camera.  I did some surgery on it about 6 months ago, to fix a problem with the LCD display that is common with these cameras.  Perhaps I did something that messed with the 1394 interface.  But the camera was working fine, until more recently when the image sensor went out.  I was hoping to continue using the camera purely as a player.

At this point you probably should resolve this bug as invalid, unless we see some other problems.

Note: the problem that I can only do ONE capture with the new camera is still annoying though...

Thanks for your time.
Comment 6 Stefan Richter 2010-05-30 11:42:18 EDT
Re comment 3 and comment 5, on your DCR-HC52:
(A recent camcorder model.)  linux1394-devel/-user received various reports of Sony camcorders behaving specially throughout the years.  Just recently, there was a report of an older Sony camcorder model (appeared on the market at about 2002) that seems to feature a firmware bug of which the older linux1394 kernel drivers were not affected, but the newer firewire drivers are.
http://thread.gmane.org/gmane.linux.kernel.firewire.user/3913
http://thread.gmane.org/gmane.linux.kernel.firewire.devel/14058
I don't know though if your "works once, then not anymore" is caused by the same issue.

Re your specimen of DCR-HC42:
Everything indicates that the port on this camera has failed. (-> not a bug)
Comment 7 Karl S. 2010-06-10 12:34:21 EDT
I found a windows machine to test and confirmed that the older camera does not work with it either, while the new one does.  So definitely a hardware problem.

Please close out this bug, thanks.  I may open a separate bug on the other issue if it continues to bother me :)
Comment 8 Stefan Richter 2010-09-15 02:47:40 EDT
Dear bugzilla handlers, please close this as not-a-bug.

Note You need to log in before you can comment on or make changes to this bug.