Bug 592003 - Xorg hangs on T500 with external monitor
Xorg hangs on T500 with external monitor
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
low Severity high
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: Triaged
: 589902 (view as bug list)
Depends On:
Blocks: 551135
  Show dependency treegraph
 
Reported: 2010-05-13 12:56 EDT by Jiri Koten
Modified: 2010-11-11 11:09 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 11:09:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (75.52 KB, text/plain)
2010-05-13 12:56 EDT, Jiri Koten
no flags Details
dmesg output (52.23 KB, text/plain)
2010-05-13 12:57 EDT, Jiri Koten
no flags Details

  None (edit)
Description Jiri Koten 2010-05-13 12:56:22 EDT
Created attachment 413812 [details]
Xorg.0.log

Description of problem:
Xorg hangs after I login to gdm (before gnome starts) on my T500 with external monitor connected. No freeze when I disconnect the monitor.
Xorg proces then hangs and cannot be killed (even with kill -9)
I use extended desktop mode in gnome.

HW: Laptop ThinkPad T500 (2241B48) 
VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
GM45 8086:2a42 
Both laptop and external monitor have 1680x1050 resolution.

Version-Release number of selected component (if applicable):
RHEL6.0-20100511.3
xorg-x11-server-Xorg-1.7.6-5.el6.x86_64
xorg-x11-drv-intel-2.10.902-1.el6.x86_64


How reproducible:
80%
Comment 1 Jiri Koten 2010-05-13 12:57:21 EDT
Created attachment 413813 [details]
dmesg output
Comment 2 RHEL Product and Program Management 2010-05-13 13:47:16 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Matěj Cepl 2010-05-17 19:39:31 EDT
INFO: task i915:169 blocked for more than 120 seconds.
"echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
i915          D ffffffffffffffff     0   169      2 0x00000000
 ffff880075f8bd50 0000000000000046 0000000000000000 0000000000000000
 0000000000000000 0000000000000000 0000000000000000 0000000000000000
 ffff880037b9fb18 ffff880075f8bfd8 000000000000fd38 ffff880037b9fb18
Call Trace:
 [<ffffffff810116e0>] ? __switch_to+0xd0/0x320
 [<ffffffff814c9992>] __mutex_lock_slowpath+0xe2/0x160
 [<ffffffff814c988b>] mutex_lock+0x2b/0x50
 [<ffffffffa00b98f0>] intel_idle_update+0x50/0x230 [i915]
 [<ffffffffa00b98a0>] ? intel_idle_update+0x0/0x230 [i915]
 [<ffffffff8108754d>] worker_thread+0x16d/0x290
 [<ffffffff8108cbb0>] ? autoremove_wake_function+0x0/0x40
 [<ffffffff810873e0>] ? worker_thread+0x0/0x290
 [<ffffffff8108c856>] kthread+0x96/0xa0
 [<ffffffff810141ca>] child_rip+0xa/0x20
 [<ffffffff8108c7c0>] ? kthread+0x0/0xa0
 [<ffffffff810141c0>] ? child_rip+0x0/0x20
INFO: task Xorg:2138 blocked for more than 120 seconds.
"echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
Xorg          D ffff88007c023080     0  2138      1 0x00400084
 ffff880078a53a48 0000000000000086 0000000000000000 ffff880001e16180
 0000000000000001 0000000000000082 ffff880078a53a18 00000000ffffa282
 ffff880072975ad8 ffff880078a53fd8 000000000000fd38 ffff880072975ad8
Call Trace:
 [<ffffffffa00a72b0>] i915_do_wait_request+0x240/0x3b0 [i915]
 [<ffffffff8108cbb0>] ? autoremove_wake_function+0x0/0x40
 [<ffffffffa00a813f>] i915_gem_object_set_to_display_plane+0xaf/0xf0 [i915]
 [<ffffffffa00b7ac0>] intel_pipe_set_base+0x130/0x4b0 [i915]
 [<ffffffff8124a938>] ? idr_get_empty_slot+0x108/0x2c0
 [<ffffffffa008f15a>] drm_crtc_helper_set_config+0x76a/0x900 [drm_kms_helper]
 [<ffffffff814c987e>] ? mutex_lock+0x1e/0x50
 [<ffffffffa0059107>] drm_mode_setcrtc+0x2b7/0x3b0 [drm]
 [<ffffffffa004bd3a>] drm_ioctl+0x32a/0x480 [drm]
 [<ffffffffa0058e50>] ? drm_mode_setcrtc+0x0/0x3b0 [drm]
 [<ffffffff8101b856>] ? __switch_to_xtra+0x126/0x200
 [<ffffffff81174772>] vfs_ioctl+0x22/0xa0
 [<ffffffff81174914>] do_vfs_ioctl+0x84/0x580
 [<ffffffff81174e91>] sys_ioctl+0x81/0xa0
 [<ffffffff81013172>] system_call_fastpath+0x16/0x1b
microcode: CPU0 sig=0x10676, pf=0x80, revision=0x60c
platform microcode: firmware: requesting intel-ucode/06-17-06
microcode: CPU1 sig=0x10676, pf=0x80, revision=0x60c
platform microcode: firmware: requesting intel-ucode/06-17-06
Microcode Update Driver: v2.00 <tigran@aivazian.fsnet.co.uk>, Peter Oruba
Microcode Update Driver: v2.00 removed.
Comment 4 Adam Jackson 2010-05-18 16:48:14 EDT
I suspect the PIPE_CONTROL fixes in upstream will help with this.  Devel ack.
Comment 6 John Villalovos 2010-05-18 19:44:55 EDT
*** Bug 589902 has been marked as a duplicate of this bug. ***
Comment 7 Aristeu Rozanski 2010-05-26 15:18:39 EDT
Patch(es) available on kernel-2.6.32-30.el6
Comment 10 Jiri Koten 2010-07-16 04:00:02 EDT
Verified in RHEL6 - Snapshot 7
Comment 11 releng-rhel@redhat.com 2010-11-11 11:09:57 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.