Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 592090 - RHEL6 Installer only detects 1 firmware raid device when there are 2
RHEL6 Installer only detects 1 firmware raid device when there are 2
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dmraid (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Heinz Mauelshagen
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-13 16:01 EDT by Aaron Gee
Modified: 2010-10-13 08:10 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-13 08:10:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/root/install.log.syslog (6.50 KB, text/plain)
2010-05-13 23:04 EDT, Aaron Gee
no flags Details
/root/install.log (21.94 KB, text/plain)
2010-05-13 23:05 EDT, Aaron Gee
no flags Details
results of dmraid -ay -t -vvv (2.17 KB, text/plain)
2010-05-15 15:31 EDT, Aaron Gee
no flags Details
/tmp/syslog at point in install where drives are shown (44.68 KB, text/plain)
2010-05-15 15:32 EDT, Aaron Gee
no flags Details
dmesg from anaconda prompt during install (39.99 KB, text/plain)
2010-05-19 11:50 EDT, Aaron Gee
no flags Details
lspci from anaconda prompt (2.39 KB, text/plain)
2010-05-19 11:51 EDT, Aaron Gee
no flags Details
dd dump of the beginning sda a corsair SSD (1.00 MB, application/octet-stream)
2010-05-19 11:52 EDT, Aaron Gee
no flags Details
dd dump of the end of sda a corsair SSD (3.10 MB, application/octet-stream)
2010-05-19 11:53 EDT, Aaron Gee
no flags Details
dd dump of the beginning of sdb a corsair SSD (1.00 MB, application/octet-stream)
2010-05-19 11:53 EDT, Aaron Gee
no flags Details
dd dump of the end of sdb a corsair SSD (3.10 MB, application/octet-stream)
2010-05-19 11:53 EDT, Aaron Gee
no flags Details
dd dump of the beginning sdc a Seagate Barracuda 7200.12 750G (1.00 MB, application/octet-stream)
2010-05-19 11:55 EDT, Aaron Gee
no flags Details
dd dump of the end of sdc a Seagate Barracuda 7200.12 750G (2.87 MB, application/octet-stream)
2010-05-19 11:55 EDT, Aaron Gee
no flags Details
dd dump of the beginning sdd a Seagate Barracuda 7200.12 750G (1.00 MB, application/octet-stream)
2010-05-19 11:56 EDT, Aaron Gee
no flags Details
dd dump of the end of sdd a Seagate Barracuda 7200.12 750G (2.87 MB, application/octet-stream)
2010-05-19 11:56 EDT, Aaron Gee
no flags Details

  None (edit)
Description Aaron Gee 2010-05-13 16:01:05 EDT
Description of problem:

Installtion of RHEL6 does not detect all bios raid drives. System has 4 drives.  2 drives are convention SATA drives and 2 are Corsair SSD.  When using BIOS based RAID, the SSD drives are not detected as raid devices (Raid 0 or 1) while the raid device configured using the conventional hard drives are


Version-Release number of selected component (if applicable):


How reproducible:Use 2 corsair SSD drives


Steps to Reproduce:
1.Install 2 corsair SSD drives
2.Use the bios to set the 2 drives in either RAID1 or RAID0
3.During install select advanced storage, click on bios raid tab.  The array is not present
  
Actual results:
No array detected

Expected results:
Array detected

Additional info:
Motherboard: Asus M4A89GTD Pro with latest firmware (Firmware dated 4/20/2010)
Chipset: AMD 890GX
Comment 2 RHEL Product and Program Management 2010-05-13 17:40:36 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Chris Lumens 2010-05-13 22:32:16 EDT
Please attach /tmp/syslog, /tmp/anaconda.log, and /tmp/storage.log to this bug report.  Thanks.
Comment 4 Aaron Gee 2010-05-13 23:04:27 EDT
Created attachment 413937 [details]
/root/install.log.syslog
Comment 5 Aaron Gee 2010-05-13 23:05:39 EDT
Created attachment 413938 [details]
/root/install.log

No /tmp log files were on my system (I went back UNDID the raid and then continued with the install).
Comment 6 Aaron Gee 2010-05-13 23:05:52 EDT
No /tmp log files were on my system (I went back UNDID the raid and then continued with the install).
Comment 7 Aaron Gee 2010-05-13 23:06:52 EDT
In my /tmp I have some sosreport-servers files.  Should I upload these as well?
Comment 8 Hans de Goede 2010-05-14 03:38:16 EDT
Aaron,

Could you reproduce the original problem, and then when at the screen which only shows the 1 raid set, switch to tty2 (ctrl + alt + f2)

And do:
dmraid -ay -t -vvv > log

And attach the resulting log file here ? (you can use scp to get the file out of the installer environment). While at it please also collect /tmp/syslog and attach it here too.

Thanks,

Hans
Comment 9 Aaron Gee 2010-05-15 15:31:19 EDT
Created attachment 414282 [details]
results of dmraid -ay -t -vvv

results of dmraid -ay -t -vvv as per request
Comment 10 Aaron Gee 2010-05-15 15:32:24 EDT
Created attachment 414283 [details]
/tmp/syslog at point in install where drives are shown

/tmp/syslog as per request.
Comment 11 Hans de Goede 2010-05-16 03:50:57 EDT
Ok, so dmraid only recognizes your 2 normal harddisks as part of a BIOS RAID set and even there I wonder if it is finding the correct metadata as it finds Promise RAID metadata, and I don't believe you have a promise controller in your system ?

My current hunch is that dmraid is not recognizing the dmraid metadata used by your BIOS RAID, and that the 2 regular disks used to be part of a promise RAID
set once upon a time and it is using that data now.

So I'm moving this over the dmraid and keeping myself in the CC.

Could you collect the following data to help out Heinz (the dmraid maintainer):
1) Tell us what sort of Firmware RAID you are using (nvidia / intel / jmicron
   or ...)
2) For each disk (after configuring it as part of a RAID set in the RAID BIOS)
   do:
   dd if=/dev/sdX of=sdX-begin.dump bs=1M count=1
   dd if=/dev/sdX of=sdx-end.dump bs=1M count=4 skip=xxxx

   Where by skip needs to be such a value that dd runs of the end of the
   disk and thus the resulting dump is smaller then 4MB (and larger then 1MB)

And then attach the dumps here.
Comment 12 Aaron Gee 2010-05-16 07:53:37 EDT
3 items

1. None of the drives had ever been used in any system, the are literally brand new just out of the packaging.

2. The RAID controller is part of the AMD SB850 southbridge, while it "looks and feels" like promise, I believe it is AMD specific and supports RAID 0,1,5,10

3. Is it possible to manually create MD devices and install on them, and or manually handle the partitioning schema?  I did not find such an option when I did the installation which is frustrating in my situation where I was trying to test a mixed SSD/Conventional disk environment for virtualization.  The default disk arrangement chosen by the installer worked - but I'd like some more flexibility.

I will get the dumps later and attach.
Comment 13 Hans de Goede 2010-05-16 08:46:59 EDT
(In reply to comment #12)
> 3 items
> 
> 1. None of the drives had ever been used in any system, the are literally brand
> new just out of the packaging.
> 

Thx, that is useful info.

> 2. The RAID controller is part of the AMD SB850 southbridge, while it "looks
> and feels" like promise, I believe it is AMD specific and supports RAID
> 0,1,5,10
> 

And yet more useful info :)

> 3. Is it possible to manually create MD devices and install on them, and or
> manually handle the partitioning schema?  I did not find such an option when I
> did the installation which is frustrating in my situation where I was trying to
> test a mixed SSD/Conventional disk environment for virtualization.  The default
> disk arrangement chosen by the installer worked - but I'd like some more
> flexibility.
> 

Yes it is possible to use a custom disklayout, when asked if you want
to remove pre-existing linux / entirely clear disks or use free space you can also choose custom partitioning, from there you can create mdraid partitions and then on top of those partitions mdraid sets.
Comment 14 Aaron Gee 2010-05-19 11:50:57 EDT
Created attachment 415167 [details]
dmesg from anaconda prompt during install
Comment 15 Aaron Gee 2010-05-19 11:51:24 EDT
Created attachment 415169 [details]
lspci from anaconda prompt
Comment 16 Aaron Gee 2010-05-19 11:52:25 EDT
Created attachment 415171 [details]
dd dump of the beginning sda a corsair SSD
Comment 17 Aaron Gee 2010-05-19 11:53:03 EDT
Created attachment 415172 [details]
dd dump of the end of sda a corsair SSD
Comment 18 Aaron Gee 2010-05-19 11:53:34 EDT
Created attachment 415173 [details]
dd dump of the beginning of sdb a corsair SSD
Comment 19 Aaron Gee 2010-05-19 11:53:59 EDT
Created attachment 415174 [details]
dd dump of the end of sdb a corsair SSD
Comment 20 Aaron Gee 2010-05-19 11:55:28 EDT
Created attachment 415177 [details]
dd dump of the beginning sdc a Seagate Barracuda 7200.12 750G
Comment 21 Aaron Gee 2010-05-19 11:55:53 EDT
Created attachment 415178 [details]
dd dump of the end of sdc a Seagate Barracuda 7200.12 750G
Comment 22 Aaron Gee 2010-05-19 11:56:20 EDT
Created attachment 415179 [details]
dd dump of the beginning sdd a Seagate Barracuda 7200.12 750G
Comment 23 Aaron Gee 2010-05-19 11:56:51 EDT
Created attachment 415180 [details]
dd dump of the end of sdd a Seagate Barracuda 7200.12 750G
Comment 24 RHEL Product and Program Management 2010-07-15 10:03:53 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 25 Heinz Mauelshagen 2010-10-13 08:10:57 EDT
(In reply to comment #17)
> Created attachment 415172 [details]
> dd dump of the end of sda a corsair SSD

This looks like Promise metadata in an unsupported offset on the disk, hence you can't use them as BIOS RAID, just mdraid.

Note You need to log in before you can comment on or make changes to this bug.