Bug 592114 - vmx and other CPU flags not shown in Xen kernel
vmx and other CPU flags not shown in Xen kernel
Status: CLOSED DUPLICATE of bug 570091
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.5
All Linux
high Severity high
: rc
: ---
Assigned To: Xen Maintainance List
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-13 18:17 EDT by Gary Case
Modified: 2010-11-09 07:41 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-13 21:28:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gary Case 2010-05-13 18:17:24 EDT
Description of problem:
The xen kernel only shows a limited number of CPU flags.

Version-Release number of selected component (if applicable):
RHEL5.5 (-194 kernel)

How reproducible:
Every time

Steps to Reproduce:
1. Install RHEL5.5 and look at /proc/cpuinfo in bare metal and xen kernels
2. Notice important CPU flags like 'vmx' are missing in xen kernel
3.
  
Actual results:
Missing CPU flags in Xen kernel

Expected results:
All CPU flags present in Xen kernel

Additional info:
This will halt system certification on any model experiencing this issue. The impact on the certification program is being discussed in Bug 576497
Comment 1 Gary Case 2010-05-13 18:18:14 EDT
Here's an example:

Core i5 650 on 5.5 Xen kernel (-194)
flags        : fpu tsc msr pae cx8 apic mtrr cmov pat clflush acpi mmx fxsr sse sse2 ss ht syscall nx lm constant_tsc ida arat pni est ssse3 cx16 sse4_1 sse4_2 popcnt lahf_lm

Core i5 650 on 5.5 bare metal kernel (-194)
flags        : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx rdtscp lm constant_tsc ida nonstop_tsc arat pni monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr sse4_1 sse4_2 popcnt lahf_lm
Comment 2 Andrew Jones 2010-05-13 21:28:05 EDT
I've thought about this issue before (see the bug I'm dupping this to). The thing is that dom0 is just a guest, so really the only way to see all the flags from it is to query the HV using some path where the HV doesn't "lie". cpuid will return whatever the HV wants to.

*** This bug has been marked as a duplicate of bug 570091 ***

Note You need to log in before you can comment on or make changes to this bug.