Bug 592116 - Dogtag: pkiremove requires perl-XML-SAX at runtime
Summary: Dogtag: pkiremove requires perl-XML-SAX at runtime
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Dogtag Certificate System
Classification: Retired
Component: Installer (pkicreate/pkiremove)
Version: unspecified
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Matthew Harmsen
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-13 22:18 UTC by Asha Akkiangady
Modified: 2015-01-06 01:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-14 17:39:32 UTC


Attachments (Terms of Use)

Description Asha Akkiangady 2010-05-13 22:18:47 UTC
Description of problem:
Dogtag: pkiremove requires perl-XML-SAX at runtime.

Version-Release number of selected component (if applicable):
Fedora 12.

How reproducible:


Steps to Reproduce:

1. Install pki packages.

2. Execute pkiremove.


Actual results:

Getting these errors during pkiremove:
Can't locate XML/SAX/Exception.pm in @INC (@INC contains: /usr/local/lib/perl5/site_perl/5.10.0/i386-linux-thread-multi /usr/local/lib/perl5/site_perl/5.10.0 /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.10.0/i386-linux-thread-multi /usr/lib/perl5/5.10.0 /usr/lib/perl5/site_perl .) at /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi/XML/LibXML.pm line 1628.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi/XML/LibXML.pm line 1628.
Compilation failed in require at /usr/bin/pkiremove line 476.
BEGIN failed--compilation aborted at /usr/bin/pkiremove line 476. 


Looks like pki-setup has a dependency on perl-XML-SAX package.

Comment 2 Kashyap Chamarthy 2010-06-03 21:50:32 UTC
It was problem with a specific machine.

Verified on a seperate machine:

'perl-XML-SAX' is (auto)installed/removed gracefully while installing 'dogtag-pki' package.


Note You need to log in before you can comment on or make changes to this bug.