Bug 592123 - SELinux is preventing /usr/libexec/accounts-daemon "create" access on custom.conf.R47BCV.
SELinux is preventing /usr/libexec/accounts-daemon "create" access on cu...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:f4f04244632...
:
: 592122 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-13 18:28 EDT by Alex Lancaster
Modified: 2010-05-18 17:48 EDT (History)
2 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-15.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-18 17:48:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2010-05-13 18:28:49 EDT
Summary:

SELinux is preventing /usr/libexec/accounts-daemon "create" access on
custom.conf.R47BCV.

Detailed Description:

[accounts-daemon has a permissive type (accountsd_t). This access was not
denied.]

SELinux denied access requested by accounts-daemon. It is not expected that this
access is required by accounts-daemon and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:accountsd_t:s0-s0:c0.c1023
Target Context                system_u:object_r:etc_t:s0
Target Objects                custom.conf.R47BCV [ file ]
Source                        accounts-daemon
Source Path                   /usr/libexec/accounts-daemon
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           accountsservice-0.6-2.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-10.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.33.3-79.fc13.x86_64 #1 SMP Mon May 3 22:37:18
                              UTC 2010 x86_64 x86_64
Alert Count                   2
First Seen                    Thu 13 May 2010 06:26:57 PM EDT
Last Seen                     Thu 13 May 2010 06:26:57 PM EDT
Local ID                      9ccd8daf-ba0d-47f7-89fa-73d590a23a18
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1273789617.551:29038): avc:  denied  { create } for  pid=26500 comm="accounts-daemon" name="custom.conf.R47BCV" scontext=system_u:system_r:accountsd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:etc_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1273789617.551:29038): avc:  denied  { write } for  pid=26500 comm="accounts-daemon" name="custom.conf.R47BCV" dev=dm-0 ino=43243 scontext=system_u:system_r:accountsd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:etc_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1273789617.551:29038): arch=c000003e syscall=2 success=yes exit=10 a0=149f580 a1=c2 a2=1b6 a3=1c items=0 ppid=1 pid=26500 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="accounts-daemon" exe="/usr/libexec/accounts-daemon" subj=system_u:system_r:accountsd_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,accounts-daemon,accountsd_t,etc_t,file,create
audit2allow suggests:

#============= accountsd_t ==============
allow accountsd_t etc_t:file { write create };
Comment 1 Alex Lancaster 2010-05-13 18:29:26 EDT
happened at the same time as bug #592122.
Comment 2 Daniel Walsh 2010-05-14 08:54:16 EDT
Fixed in selinux-policy-3.7.19-15.fc13.noarch
Comment 3 Daniel Walsh 2010-05-14 08:55:47 EDT
*** Bug 592122 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2010-05-14 08:56:22 EDT
selinux-policy-3.7.19-15.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-15.fc13
Comment 5 Fedora Update System 2010-05-15 16:22:27 EDT
selinux-policy-3.7.19-15.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-15.fc13
Comment 6 Fedora Update System 2010-05-18 17:47:00 EDT
selinux-policy-3.7.19-15.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.