Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 592136 - System reports it is still on AC power when already on battery
System reports it is still on AC power when already on battery
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-13 20:11 EDT by Rui Matos
Modified: 2011-06-27 12:20 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-27 12:20:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rui Matos 2010-05-13 20:11:28 EDT
When I hibernate my Sony Vaio VPCS11X9E laptop when it is still plugged and then turn it on unplugged the system can't detect that it's now running on battery power.

I think the problem is in the kernel because I've tried to kill and restart both gnome-power-manager and upowerd and both didn't solve the issue. Also powertop reports that "no ACPI power usage estimate available".

This is what 'upower -d' reports:

$ upower -d
Device: /org/freedesktop/UPower/devices/line_power_AC
  native-path:          /sys/devices/LNXSYSTM:00/LNXSYBUS:00/ACPI0003:00/power_supply/AC
  power supply:         yes
  updated:              Fri May 14 00:43:51 2010 (1456 seconds ago)
  has history:          no
  has statistics:       no
  line-power
    online:             yes

Device: /org/freedesktop/UPower/devices/battery_BAT1
  native-path:          /sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0A:00/power_supply/BAT1
  vendor:               Sony Corp.
  model:                VGP-BPS21A
  serial:               16070
  power supply:         yes
  updated:              Fri May 14 01:07:58 2010 (9 seconds ago)
  has history:          yes
  has statistics:       yes
  battery
    present:             yes
    rechargeable:        yes
    state:               fully-charged
    energy:              51.49 Wh
    energy-empty:        0 Wh
    energy-full:         57.24 Wh
    energy-full-design:  57.24 Wh
    energy-rate:         11.74 W
    voltage:             3.728 V
    percentage:          89.9546%
    capacity:            100%
    technology:          lithium-ion
  History (charge):
    1273795678	89.955	fully-charged
    1273795648	90.147	fully-charged
    1273795618	90.269	fully-charged
    1273795588	90.321	fully-charged
  History (rate):
    1273795678	11.740	fully-charged
    1273795648	12.010	fully-charged
    1273795618	12.100	fully-charged
    1273795588	11.740	fully-charged

Daemon:
  daemon-version:  0.9.3
  can-suspend:     yes
  can-hibernate    yes
  on-battery:      no
  on-low-battery:  no
  lid-is-closed:   no
  lid-is-present:   yes


I'm pretty sure it is unplugged as I run that command :-)

Package version:
kernel-PAE-2.6.33.3-85.fc13.i686
Comment 1 Bug Zapper 2011-06-02 10:04:09 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Bug Zapper 2011-06-27 12:20:54 EDT
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.