Bug 592138 - When connecting to xrdp, mouse pointer is surrounded by a black square
Summary: When connecting to xrdp, mouse pointer is surrounded by a black square
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-14 00:21 UTC by Bojan Smojver
Modified: 2018-04-11 08:58 UTC (History)
3 users (show)

Fixed In Version: xorg-x11-drv-intel-2.12.0-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-22 09:53:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot, showing the mouse pointer as it should be (39.39 KB, image/png)
2010-05-14 00:21 UTC, Bojan Smojver
no flags Details
Screen photo, showing the mouse pointer surrounded by a black square (439.40 KB, image/png)
2010-05-14 00:33 UTC, Bojan Smojver
no flags Details

Description Bojan Smojver 2010-05-14 00:21:34 UTC
Created attachment 413921 [details]
Screenshot, showing the mouse pointer as it should be

Description of problem:
When connecting to xrdp, mouse pointer is surrounded by a black square.

Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.11.0-4.fc13.i686

How reproducible:
Always.

Steps to Reproduce:
1. Install Citrix ICA client 11.100 on F-13 (use --nodeps).
2. Connect to Citrix server over HTTPS (FF).
3. Open an RDP session to xrdp running on F-13.
  
Actual results:
Mouse pointer surrounded by black square.

Expected results:
This used to work under F-12, at least with Citrix client 10.6 (which if used with F-13 leaves artefacts; 10.100 had other pointer problems under F-12, see: http://forums.citrix.com/thread.jspa?messageID=1440201&#1440201). Also, it works with a ATI Mobility Radeon HD 5470 under F-13 and Citrix client 11.100.

Additional info:
I'm attaching the screenshot, which doesn't show the problem - yeah, I know. Funnily enough, the pointer on the screenshot is the way it's supposed to be, meaning it probably is a display problem.

Apologies for proprietary software in between, but I'm forced by the environment to use it. To my knowledge, there is no free ICA clients out there.

Switching between compiz and metacity does not make any difference.

Comment 1 Bojan Smojver 2010-05-14 00:33:21 UTC
Created attachment 413923 [details]
Screen photo, showing the mouse pointer surrounded by a black square

Comment 2 Bojan Smojver 2010-05-14 01:09:24 UTC
One more piece of information. When the cursor turns to hourglass, because Citrix is supposedly busy, everything is fine. I'm guessing that's because Citrix client is an app running directly on this Xorg server, not a remote one.

Comment 3 Bojan Smojver 2010-07-20 07:39:31 UTC
Fixed in xorg-x11-drv-intel-2.12.0-1.fc13, as my brief testing appears to show. Could we have this pushed to updates?

Comment 4 Bojan Smojver 2010-07-20 07:44:30 UTC
Oh, and if it matters, I used 2.6.34.1-20.fc13.x86_64 kernel (which I guess should also go to updates soon).

Comment 5 Bojan Smojver 2010-07-20 10:53:16 UTC
(In reply to comment #4)
> Oh, and if it matters, I used 2.6.34.1-20.fc13.x86_64 kernel (which I guess
> should also go to updates soon).    

One more thing, if we could have that UXA planemask patch (http://cvs.fedoraproject.org/viewvc/rpms/xorg-x11-drv-intel/devel/intel-2.12-fix-uxa-planemask.patch?view=log) ported to F-13, that would be even better.

Comment 6 Matěj Cepl 2010-07-22 09:53:07 UTC
Thank you for letting us know.

Comment 7 Matěj Cepl 2010-07-22 09:54:14 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > Oh, and if it matters, I used 2.6.34.1-20.fc13.x86_64 kernel (which I guess
> > should also go to updates soon).    
> 
> One more thing, if we could have that UXA planemask patch
> (http://cvs.fedoraproject.org/viewvc/rpms/xorg-x11-drv-intel/devel/intel-2.12-fix-uxa-planemask.patch?view=log)
> ported to F-13, that would be even better.    

Please, file a separate bug for this with explanation what it is good for and what problem it resolves.

Thank you

Comment 8 Bojan Smojver 2010-07-22 11:17:34 UTC
(In reply to comment #7)
 
> Please, file a separate bug for this with explanation what it is good for and
> what problem it resolves.

Kinda seems obvious from the patch:
-------------------
planemask is an unsigned long initialised to ~0, on 64-bit this is not equal to an (unsigned int)-1.

Use the macro provided to do this.
-------------------

What problem it specifically resolves, I cannot tell you, but it seems that it may affect 64-bit archs.

Comment 9 Bojan Smojver 2010-09-06 23:24:19 UTC
(In reply to comment #6)
> Thank you for letting us know.

Can we see this queued up as an update to F-13? I've been running it for a while now, mostly trouble free, so it would be good to see what other folks think about it.


Note You need to log in before you can comment on or make changes to this bug.