Bug 592140 - Enabling kdump at the end of firstboot fails
Enabling kdump at the end of firstboot fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kexec-tools (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Neil Horman
Han Pingtian
:
Depends On:
Blocks: 524819
  Show dependency treegraph
 
Reported: 2010-05-13 20:23 EDT by Brian Lane
Modified: 2010-11-10 15:59 EST (History)
1 user (show)

See Also:
Fixed In Version: kexec-tools-2.0.0-70
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 15:59:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
grub.conf from EFI system install (834 bytes, text/plain)
2010-05-14 13:13 EDT, Brian Lane
no flags Details
output of parted -l on the EFI system (1.16 KB, text/plain)
2010-05-14 13:14 EDT, Brian Lane
no flags Details
patch to look for grub.conf correctly (673 bytes, patch)
2010-05-19 06:49 EDT, Neil Horman
no flags Details | Diff
updated patch (1.68 KB, patch)
2010-05-19 15:56 EDT, Neil Horman
no flags Details | Diff
working patch (1.38 KB, patch)
2010-05-19 19:15 EDT, Brian Lane
no flags Details | Diff

  None (edit)
Description Brian Lane 2010-05-13 20:23:20 EDT
Description of problem:
I tried to enable kdump at the end of firstboot, it warned me that it needed to reboot, I selected ok and it displayed an error: 'Error! No bootloader config file found, aborting configuration!'

Clicked ok and it returned to the kdump page with it disabled. I completed the install successfully with it disabled.

Version-Release number of selected component (if applicable):
firstboot-1.110.2-1.el6.x86_64

How reproducible:
Unknown, I have tried once so far.



Additional info:

I couldn't find any firstboot logs related to kdump or the error. I checked the anaconda logs and they have nothing as well.
Comment 2 RHEL Product and Program Management 2010-05-13 22:38:52 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Martin Gracik 2010-05-14 03:39:37 EDT
Hi Brian,

I tried to reproduce this, I installed nightly from May 11th, with firstboot-1.110.2-1. In firstboot, right after restart, I enabled kdump, in the dialog about restart needed, I pressed Yes, and got no error message, everything went fine.

So I could not reproduce it, can you try yourself again?
Comment 4 Brian Lane 2010-05-14 13:12:45 EDT
I tried the install using the same .iso on a virt (single disk, use all space) and it enables kdump just fine.

I tried running firstboot on the EFI system and it had the same problem. I did a reinstall just to be sure and it still won't enable kdump.

I'll attach my grub.conf and parted -l output. Let me know if there are any other files to look at, as far as I can tell firstboot isn't logging anything.
Comment 5 Brian Lane 2010-05-14 13:13:36 EDT
Created attachment 414116 [details]
grub.conf from EFI system install
Comment 6 Brian Lane 2010-05-14 13:14:06 EDT
Created attachment 414117 [details]
output of parted -l on the EFI system
Comment 7 Brian Lane 2010-05-17 11:49:57 EDT
More info:

/boot is mounted, but some of the files are in different locations.

/etc/grub.conf exists (attached above)
/boot/grub/ only has device.map and splash.xpm.gz in it, no grub.conf

/boot/efi is a separate partition and it has grub.conf in it:

/boot/efi/EFI/redhat/grub.conf 
/boot/efi/EFI/redhat/grub.efi

So, if firstboot/kdump is looking for /boot/grub/grub.conf it isn't going to find it.

/etc/grub.conf is a symlink to /boot/efi/EFI/redhat/grub.conf
Comment 8 Neil Horman 2010-05-19 06:48:06 EDT
yeah, we're looking for /boot/grub/grub.conf.  I'll put together a patch
Comment 9 Neil Horman 2010-05-19 06:49:43 EDT
Created attachment 415083 [details]
patch to look for grub.conf correctly

I think this should do it, could you please test this out and confirm that firstbook works properly for you?  Thanks!
Comment 10 Brian Lane 2010-05-19 12:34:54 EDT
That won't work, you're adding a new grub entry pointing to the efi config, but that overwrites the previous entry in the dict.

I'd suggest either testing for /etc/grub.conf (assuming it always points to the right place -- I don't know enough to be sure of this) or making the bootloaders dict support lists of config files to test for, eg:

bootloaders = { "grub"   : [("/boot/grub/grub.conf", 16),
                            ("/boot/efi/EFI/redhat/grub.conf", 256)],
                "yaboot" : [("/boot/etc/yaboot.conf", 32)],
                "elilo"  : [("/boot/efi/EFI/redhat/elilo.conf", 256)],
              }
Comment 11 Neil Horman 2010-05-19 13:12:44 EDT
Dang your right, its a dict not a list of lists.  I'll fix up the patch to do the latter suggestion I think.  Thanks!
Comment 12 Neil Horman 2010-05-19 15:56:51 EDT
Created attachment 415243 [details]
updated patch

here you go.  I've not tested it yet, but I think this should make the bootloaders dictionary list aware, and let us match multiple entries for each name.
Comment 13 Brian Lane 2010-05-19 19:15:43 EDT
Created attachment 415284 [details]
working patch
Comment 14 Brian Lane 2010-05-19 19:16:27 EDT
Attached is a tested patch. I store the offset in the instance so that the bootloaders don't need to be scanned every time the offset is needed.
Comment 20 releng-rhel@redhat.com 2010-11-10 15:59:50 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.